Ask Your Question

Revision history [back]

Why is plymouth unable to see my nvidia card during boot?

I am trying to change the theme used by plymouth on my fresh-installed, nvidia-carded F16 install. Through appending plymouth:debug I can see that it fails to open the dri render, tried the framebuffer one, notices that the x11 one is not available either, so falls back to the text mode one.

[ply-renderer.c] ply_renderer_open_plugin:trying to open renderer plugin /usr/lib64/plymouth/renderers/
[./plugin.c] create_backend:creating renderer backend for device /dev/dri/card0
[./plugin.c] load_driver:Attempting to load driver '(null)'
[./plugin.c] load_driver:drmOpen failed
[ply-renderer.c] ply_renderer_open_plugin:could not open rendering device for plugin /usr/lib64/plymouth/renderers/

Sure enough I don't have a /dev/dri folder at all once I'm finished booting.

My research so far has found this message on the Plymouth mailing list where it is stated that I have to ensure my kernel modesetting driver is loaded. That doesn't make much sense to me.

I found this Fedora wiki document helped me understand this a bit more. Looking in my grub2.cfg I found that the option they mention is, in fact, disabled. So I tried re-enabling it, but this had no effect. I still had the same problem in my plymouth log.

This may be because I'm using the nvidia rpmfusion driver? I don't know.

So does FC16 have this disabled by default for some reason? Have I lost the ability to have a graphic boot splash by installing the nvidia drivers? Is there any way to continue to investigate this issue?