Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

The installpage says the Live version is "complete" -- why can't I use e.g. dnf?

I was under the impression that when the install page described the Live USB version as "complete" that I would receive a regular OS installation on the USB, including persistence. Anything else just wouldn't be complete in my eyes.

But when I run it I run into nothing but problems. I couldn't install nvidia drivers because whenever I did something with dnf it complained about a read-only fs: Config error: Read-only file system: /var/log/dnf.log. I ran using sudo and compared the permissions for the complete path to that file to "working" permissions posted by another user here. I couldn't install applications from the store.

The only two things that worked out-of-the-box were multimon support and wifi (not a bad accomplishment in itself] but I thought "test and play" meant more than just launching stock apps.

Q: Was I mistaken about the Live version - can't I find out e.g. if Fedora works with proprietary nvidia drivers without investing in partitioning and installing on internal media

(can't type questionmarks, and many other characters, in the question body since this site is interfering with my keyboard layout, sorry about that]

I used Fedora 25 with Fedora media writer from Windows 10.