Fedora 25: GDM breaks after installing nVidia drivers (GeForce 940M)

asked 2017-01-05 07:57:36 -0500

Mateus Felipe gravatar image

I recently bought a new laptot, an Acer E15, which comes with a 940M GPU. After installing Fedora 25 everything worked fine. Then, I installed nVidia drivers according to this page:

  1. I enabled Fusion free and non-free.
  2. I installed drivers through # dnf install xorg-x11-drv-nvidia akmod-nvidia "kernel-devel-uname-r == $(uname -r)"
  3. I upgraded xorg-server with # dnf update xorg-x11-server\* --enablerepo=updates-testing as this nVidia Optimus article instructs.

After rebooting, gdm doesn't starts. It shows that "Oops! Something gone wrong!" screen, and if I try to restart it, happens again and again. I tried to rollback through # dnf history rollback but it did not work. I had to install a fresh system again. How can I enable proprietary nVidia drivers for my laptop without breaking it?

edit retag flag offensive close merge delete

Comments

Post the output for this command (upload and attach).

nvidia-bug-report.sh

Shame you have reinstalled as it is unlikely to be resolved without any debugging!

geforce gravatar imagegeforce ( 2017-01-05 11:52:56 -0500 )edit

@leigh123linux Nvidia driver is not installed anymore, if I install it, I wont be able to boot to give you this information. How could I do it? Thanks.

Mateus Felipe gravatar imageMateus Felipe ( 2017-01-05 12:10:33 -0500 )edit

I have ported most of the changes needed for the rpmfusion driver to work with optimus, the kernel option 'nvidia-drm.modeset=1' seems to be required. Switching still requires some mesa changes.

  1. fully update the install
  2. install kernel-devel
  3. boot the new kernel
  4. edit /etc/default/grub and add kernel options ( include nouveau blacklist ).
  5. install rpmfusion nvidia driver
  6. wait 5 minutes to allow module to build
  7. run 'akmods --force' just to be sure

http://hansdegoede.livejournal.com/

https://wiki.realmofespionage.xyz/distros:fedoraworkstationgnome#proprietary_graphic

geforce gravatar imagegeforce ( 2017-01-05 15:56:41 -0500 )edit

pray and reboot Switching wont work but it should default to nvidia.

I don't have optimus to test changes so it might fail.

geforce gravatar imagegeforce ( 2017-01-05 15:59:41 -0500 )edit