Ask Your Question
2

Why doesn't the delete key work in Gnome3?

asked 2012-02-07 09:40:41 -0500

viajeramental gravatar image

updated 2012-02-07 21:34:11 -0500

FranciscoD_ gravatar image

Hello all!

 I use a netbook with Atom N450, 1GB RAM and a 160GBs hard disk.  I have installed in my Fedora 16 three desktops: KDE, Cinnamon and Gnome 3.

In KDE Delete key of my keyboard (Del, in my spanish kb is Supr) works well. In Gnome it doesn't work. I have to right-click on the item and select "Move to trash". Somebody know why? There's some way to fix it?

Thanks very much!

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
2

answered 2012-02-07 10:28:43 -0500

skytux gravatar image
edit flag offensive delete link more
5

answered 2012-02-07 16:57:43 -0500

shaiton gravatar image

You need to hit

[CTRL]+[DEL]

They've added that (GNOME devs) to prevent unwanted delete…

edit flag offensive delete link more
2

answered 2015-03-24 06:48:45 -0500

deadrat gravatar image

If you want to move a selected item(s) to Wastebasket, press Ctrl and Delete together.

If you want to permanently delete a selected item, press Shift and Delete together.

If you want to use Delete key to move a selected item(s) to Wastebasket,

edit ~/.config/nautilus/accels file ( u may type sudo gedit ~/.config/nautilus/accels )

look for ; (gtk_accel_path "<actions>/DirViewActions/Trash" "<primary>Delete") </primary></actions>

uncomment by removing the semicolon and change to the command you want to use. e.g. (gtk_accel_path "<Actions>/DirViewActions/Trash" "Delete")

edit flag offensive delete link more
0

answered 2015-03-24 03:06:40 -0500

resgef.com gravatar image

updated 2015-03-24 03:10:53 -0500

Its nice, Ctrl+Delete to prevent unwanted deletion.


"some coders php is better then his English"

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-02-07 09:40:41 -0500

Seen: 8,103 times

Last updated: Mar 24 '15