Ask Your Question

F25 Steam stops working after NVIDIA drivers are installed

asked 2017-01-03 13:12:27 -0500

Everything was working fine, however I was getting terrible performance in games, so I decided to install the NVIDIA drivers for my card following this guide:

Now my Steam will not open and gives the following error when run:

Running Steam on fedora 25 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1482202200)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

I have tried many things I found online, including this:

However nothing seems to work, any ideas?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2017-01-03 13:30:37 -0500

Ah, silly fix. Install xorg-x11-drv-nvidia-libs.i686 to fix.

dnf install xorg-x11-drv-nvidia-libs.i686


edit flag offensive delete link more

answered 2017-01-04 18:25:53 -0500

xmetax gravatar image

updated 2017-01-04 18:27:55 -0500

I fix that by reinstalling the NVIDIA driver. The above post may be a shorter fix, but this works for me every time.

# systemctl set-default
# reboot


nvidia-installer --force-update

The NVIDIA installer downloads the latest driver, uninstalls the present one, and installs the new one.

systemctl set-default

Choose to build the DKMS module, install the 32-bit libs, and create a new xorg.conf file if desired.

Complete. Now reboot and test.

Note: This works on the latest NVIDIA driver version, for olders versions, you'll need to have the binary installer downloaded and use the --uninstall option instead then install after reboot.

Good luck and I welcome anyone's feedback.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2017-01-03 13:12:27 -0500

Seen: 554 times

Last updated: Jan 04 '17