Ask Your Question
1

What is the easiest way to install Fedora 25 with UEFI?

asked 2017-01-03 07:24:30 -0500

Mo-hd gravatar image

updated 2017-01-03 23:54:37 -0500

Hi,

I'm having a trouble here trying to Install Fedora 25 MATE with UEFI, i cant find a Legacy boot, i only have a UEFI with an Enable or Disable. When i boot Fedora from my USB it give me 3 option Install, Test, Troubleshooting. Choosing Install or Test give me a get a black screen. that stay and i cant do anything.

I'm using Asus K43S. I'm using Windows 8.1. and want to Install Fedora 25 in UEFI Mode as Dual Boot.

Thank You.

edit retag flag offensive close merge delete

Comments

Use you Fedora installation image with default partition.

aeperezt gravatar imageaeperezt ( 2017-01-03 09:31:17 -0500 )edit

Cant do anything. choosing Install or Test give me a black screen.

Mo-hd gravatar imageMo-hd ( 2017-01-03 23:56:53 -0500 )edit

On you video you show the bios, but you are not showing us what happen when you try to boot and install, are you able to boot and load the install media?

aeperezt gravatar imageaeperezt ( 2017-01-04 09:09:58 -0500 )edit
  • aeperezt
  • cmurf

Thank you for your help really appreciate it.

Mo-hd gravatar imageMo-hd ( 2017-01-05 04:43:48 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-01-03 21:23:35 -0500

harrybrush gravatar image

Did you disable secure boot? That can often be a culprit. I was able to dual boot with Windows 10 with UEFI (Thinkpad T460s) following these guidelines: http://linuxbsdos.com/2016/12/01/dual...

When installing, I read a couple places that the default partition scheme can cause problems on some firmware. The "custom partition" here is probably very similar to the default. For my system, I had to get /boot/efi to mount by doing the automatic partition and then manually remove and remount /, /home. and swap.

edit flag offensive delete link more

Comments

I don't see secure boot. I uploaded a video here: https://www.youtube.com/watch?v=JPTdQ...

Mo-hd gravatar imageMo-hd ( 2017-01-04 04:28:20 -0500 )edit

Some additional sanity checks:

  • Under the boot tab, you only have your SSD (I'm assuming that's the internal SSD of your machine) as a boot option. Try adding external USB (or DVD) to that list and try again. You may find this guide from the Asus website very helpful.

  • Something might be wrong with your installation image, it does happen occasionally. If you have Win10 around, try installing MobaLiveCD and run as Adminstrator to see if it boots or not.

Otherwise, the cmurf's advice above can help with BIOS

harrybrush gravatar imageharrybrush ( 2017-01-04 12:52:10 -0500 )edit

Ok so i use Rufus, then try adding external USB the first at the boot option, save, reboot, then select Install few seconds and it Worked!!!! :) Thank you for your help really appreciate it.

Mo-hd gravatar imageMo-hd ( 2017-01-05 04:41:31 -0500 )edit
1

answered 2017-01-04 12:26:47 -0500

cmurf gravatar image

UEFI Boot = disabled is the same as legacy boot, poorly named. Don't disable UEFI. Windows is installed with UEFI enabled, and mixed boot mode isn't supported. Try going to the Troubleshooting menu, find the basic video option and highlight it, press 'e' to edit that boot option, on the linuxefi line find and remove the rhgb and quiet options if present. That'll reveal boot text and hopefully find out where the problem is, or maybe you get lucky and basic video will work. Use F10 or Ctrl-X to boot this edited boot entry.

edit flag offensive delete link more

Comments

Also, whatever you do, don't delete or reformat the EFI System partition, a.k.a. /boot/efi. Doing so will render Windows unbootable.

cmurf gravatar imagecmurf ( 2017-01-04 12:28:32 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2017-01-03 07:10:06 -0500

Seen: 9,893 times

Last updated: Jan 05 '17