Ask Your Question

Fedora 25: Permanent enable dedicated graphics card.

asked 2017-01-02 07:53:58 -0500

Nevermind gravatar image

Hi, I recently upgraded to Fedora 25 but have some difficulties enabling my dedicated AMD video card.

I've already tried using vga-switcheroo, but without success (tested after logout and after restart):

echo ON > /sys/kernel/debug/vgaswitcheroo/switch
echo DIS > /sys/kernel/debug/vgaswitcheroo/switch
echo DDIS > /sys/kernel/debug/vgaswitcheroo/switch

Output of cat /sys/kernel/debug/vgaswitcheroo/switch:

1:DIS: :DynOff:0000:01:00.0

My question is - How to permanent enable the dedicated video card in Fedora 25?

edit retag flag offensive close merge delete



If you have two Video card and want to permanent have one disable you can add it to the kernel blacklisted module, find which module use and add a file on /etc/modprobe.d/mycard.conf and add a line like "blacklist i915", that way you will only have the module for the AMD card and it will always run.

aeperezt gravatar imageaeperezt ( 2017-01-02 09:00:48 -0500 )edit

@aeperezt thanks for the reply. I suppose that "i915" stands for the graphic card model, but how to determine the correct name format or is it the same as the one returned in the lspci list?

Nevermind gravatar imageNevermind ( 2017-01-02 14:19:23 -0500 )edit

You are right i915 is the name of the kernel module of the Intel module, you need to use lsmod to list all your modules and modinfo to get information of a specific one. If you have the video card manufacture and model you may query the kernel module on google.

aeperezt gravatar imageaeperezt ( 2017-01-02 17:37:04 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-01-03 09:14:47 -0500

rhandwor52 gravatar image

I would check your bios. When starting up push delete when bios comes up scroll to video card. Set what you want then push f10 save.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2017-01-02 07:44:28 -0500

Seen: 770 times

Last updated: Jan 03 '17