Ask Your Question
0

Fedora 25 new install - Can't get an IPV4, only IPV6

asked 2016-12-27 13:34:29 -0500

Erasmix gravatar image

Hello,

I'm attempting a fresh F25 install on clean drive. I first noticed I couldn't get to some websites, either with FF or Chrome. A little research seemed indicate this is due to the use of IPV6. ifconfig shows an IPV6 but not an IPV4. I tried disabling IPV6 on System -> Network {IPV4 is ON and Automatic(DHCP)} but I can't get an IPV4 from my router and I loose all network connectivity until I re-enable IPV6. I just need IPV4 to work as all my other computer/devices that depend on this box are on IPV4.

This was working fine on my previous Fedora (20?). I have a linksys router which assigns a specific IPV4 based on the MAC Address of this box. I simply put in a new drive and install the latest fedora but never before I had this problem. Can someone please help?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2016-12-27 15:15:23 -0500

sideburns gravatar image

Welcome to ask.fedora. From what you write, you've tried telling your computer to Ignore IPv6. Along with that, try setting IPv4 to Manual, and give it the same IP address, Gateway and DNS servers that your router does. (You don't really need your router to give an IP address if you do this, because your computer won't be using DHCP, but it won't hurt.) I don't know why your box is ignoring IPv4, but this might work around it.

edit flag offensive delete link more

Comments

Great minds think alike!! Setting the IP manually works and I can connect to the websites I was failing to connect before.Thank you so much!!!

Erasmix gravatar imageErasmix ( 2016-12-28 12:32:35 -0500 )edit
1

answered 2016-12-27 18:08:20 -0500

Rabin gravatar image
  • Try to disable the Firewall to make sure the DHCP client packets are not dropped.
  • Maybe running Wireshark to validate this.
  • Also make sure your router have external IPv4 address
  • Make sure the route have a DHCP pool for IPv4 and it's enabled.
edit flag offensive delete link more

Comments

I have the firewalld service disabled. Yes I do have an external IPV4 address assigned by my ISP. All other computers and devices in my home LAN get an IPV4 from the linksys router. Remember this used to work before the upgrade. I can boot off my previous fedora HD and it works perfectly. For some reason that escapes me it's ignoring IPV4. I don't think I did a special install (Installed Fedora Server then added Fedora Workstation on top).

Erasmix gravatar imageErasmix ( 2016-12-28 12:36:09 -0500 )edit
-1

answered 2016-12-29 08:51:30 -0500

rhandwor52 gravatar image

I open the firewall on the drop down box click permanent. Then I set the left column the way I want, Then I set ports needed.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-12-27 13:34:29 -0500

Seen: 1,315 times

Last updated: Dec 29 '16