Ask Your Question
0

# dnf upgrade --refersh Failed to synchronize cache for repo 'fedora-steam', disabling

asked 2016-12-22 22:15:14 -0500

anwer gravatar image

dnf upgrade --refersh

Failed to synchronize cache for repo 'fedora-steam', disabling.-:-- ETA

edit retag flag offensive close merge delete

Comments

disable fedora-steam repository edit file on /etc/yum.repo.d/fedora-steam and set enable=0 they try it again.

aeperezt gravatar imageaeperezt ( 2016-12-22 23:19:52 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-12-23 07:26:29 -0500

mithrial gravatar image

I don't know where you get that repository from but it is not from the official repositories.

You have a few options to proceed:

  1. Disable the repository altogether by either remove the file rm /etc/yum.repos.d/fedora-steam.repo, or open that file and change the value enabled=1 to enabled=0. This disables this repo forever (until you change it back).
  2. Skip the repo if it is unavailable by introducing the setting skip_if_unavailable=True into the same file. On each update, dnf will try to connect to the repo but skip it if it's not available and continue with other repos.
  3. Check why it is unavailable: I guess that you upgraded to Fedora 25 but the third-party repostory doesn't support the new version (yet). You can apply option 2 and hope for the maintainers to supply a compatible version.
  4. Or you can enforce using the old 24 version by changing the same file and replace $releasever with 24. I don't recommend this.
edit flag offensive delete link more

Comments

thanks a lot now ti's work normally after remove file thanks again

anwer gravatar imageanwer ( 2016-12-23 23:24:22 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-12-22 22:15:14 -0500

Seen: 1,614 times

Last updated: Dec 23 '16