Ask Your Question
1

VLC no longer working on Fedora25 after updates [closed]

asked 2016-12-21 17:24:53 -0500

technog1 gravatar image

VLC was behaiving a bit odd after upgrading to Fedora 25. But it was working. After the last OS updates, vlc now wont start at all. I just keep getting a popup error message box that states glc hsa crashed. Every time.

tia,

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by florian
close date 2018-06-28 09:43:32.191010

5 Answers

Sort by ยป oldest newest most voted
2

answered 2016-12-23 01:12:23 -0500

geforce gravatar image

updated 2016-12-23 01:12:50 -0500

vlc-3.0.0-0.12.fc25 is broken by wayland, rpmfusion have removed the package from updates, The solution is to downgrade to vlc-3.0.0-0.11.fc25

sudo dnf downgade vlc\*
edit flag offensive delete link more

Comments

Thanks! this resolved the issue. Downgrading vlc is the way to go.

technog1 gravatar imagetechnog1 ( 2016-12-23 10:54:37 -0500 )edit

Helped, and VLC will run, but not when trying to open a video file.

gtomas gravatar imagegtomas ( 2017-05-14 06:50:38 -0500 )edit

Install from UnitedRPMs; I am using in Gnome with wayland in my tv 60's without problem..

davidva gravatar imagedavidva ( 2017-07-12 18:52:00 -0500 )edit
1

answered 2016-12-22 04:06:23 -0500

padraic gravatar image

updated 2016-12-23 03:39:24 -0500

I find that I have problems with VLC every time I update Fedora version. It happens because I don't manage my third party repos very well and usually mess something up.

If you can find out what repo VLC is being provided from it might help you troubleshoot. Try

$ dnf list vlc

What you get back should be something like

vlc                        1.13.1-3.fc24              @rpmfusion

So if this was what you saw it would mean that you have vlc version 1.12.1-3 packaged for Fedora 24, from the RPMfusion repo.

In my own case I had vlc installed from RPM Fusion and couldn't get it to work. If you are in the same situation you have two options:

  1. Do what I did. I uninstalled VLC and added the repo for UnitedRPMS (instructions here./README.md)

  2. Do what Leigh recommends below and downgrade VLC. (I haven't tried this myself).

edit flag offensive delete link more

Comments

1

I have the same issue and the output from dnf list vlc command is:

vlc.x86_64 3.0.0-0.12.fc25 @rpmfusion-free-updates

q2dg gravatar imageq2dg ( 2016-12-22 14:09:11 -0500 )edit

oh you're right - I should have said $ dnf list vlc

and not 'search'. Thanks!

padraic gravatar imagepadraic ( 2016-12-23 03:32:49 -0500 )edit
0

answered 2017-07-12 14:12:20 -0500

grenade gravatar image

updated 2017-07-12 14:13:23 -0500

VLC believed it is the latest version, but I had only audio, no video on FC 25. VLC was actually at version 3.0.0-0.28.git20170622.fc25 (I needed 3.0.0-0.29.git20170622.fc25) until I ran:

sudo dnf install vlc vlc-core --best --allowerasing

This apparently re-installed and upgraded the version I had installed. After running this command, VLC works properly again.

edit flag offensive delete link more
0

answered 2016-12-22 10:18:26 -0500

technog1 gravatar image

updated 2016-12-22 10:19:58 -0500

Wanted to reply to comment above, but too long for that. This is the output of the above command:

google-chrome 50 kB/s | 3.7 kB 00:00
Fedora 25 - x8664 - Updates 3.9 MB/s | 13 MB 00:03
RPM Fusion for Fedora 25 - Free - Updates 1.5 MB/s | 185 kB 00:00
RPM Fusion for Fedora 25 - Nonfree 1.3 MB/s | 144 kB 00:00
Adobe Systems Incorporated 16 kB/s | 2.0 kB 00:00
RPM Fusion for Fedora 25 - Free 2.3 MB/s | 515 kB 00:00
RPM Fusion for Fedora 25 - Nonfree - Updates 288 kB/s | 17 kB 00:00
Fedora 25 - x86
64 4.0 MB/s | 50 MB 00:12
Last metadata expiration check: 0:00:23 ago on Thu Dec 22 10:59:17 2016. ====================================================== N/S Matched: vlc ======================================================= vlc.x86_64 : The cross-platform open-source multimedia framework, player and server

vlc-core.x86_64 : VLC media player core

vlc-core.i686 : VLC media player core

npapi-vlc.x86_64 : NPAPI plugin for libvlc

vlc-devel.i686 : Development files for vlc

vlc-devel.x86_64 : Development files for vlc

phonon-backend-vlc.x86_64 : VLC phonon backend

phonon-qt5-backend-vlc.x86_64 : Vlc phonon-qt5 backend

vlc-extras.x86_64 : VLC media player with extras modules

python2-vlc.noarch : VLC Media Player binding for Python

python3-vlc.noarch : VLC Media Player binding for Python

npapi-vlc-gtk.x86_64 : NPAPI plugin for libvlc - gtk version

npapi-vlc-filesystem.x86_64 : NPAPI plugin for libvlc - filesystem

edit flag offensive delete link more

Comments

I quoted the wrong command above - I should have said $ dnf list vlc and not search. I am going to edit my answer to change this.

padraic gravatar imagepadraic ( 2016-12-23 03:34:07 -0500 )edit
0

answered 2016-12-23 10:53:05 -0500

technog1 gravatar image

So the answer is that vlc is broken in wayland as per above. And leigh123linux's suggestion of the downgrade worked! vlc seems to be functioning normally again.

Thanks!

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-12-21 17:24:53 -0500

Seen: 3,407 times

Last updated: Jun 28 '18