Ask Your Question

Upgrade to Fedora 25 fails due to error about google-earth

asked 2016-12-20 23:50:25 -0500

wawa gravatar image

updated 2016-12-22 18:56:15 -0500

mattdm gravatar image

Dear all; every time I start F24, it tells me an important upgrade is available: Fedora 25. Clicking the 'Download' button results in a lengthy process of RG+HDD activity with an error: Sorry, this did not work Upgrade to Fedora 25 failed. Details

Detailed errors from the package manager follow:
package google-earth-stable- cannot be verified and repo google-earth is GPG enabled: failed to lookup digest in keyring for /var/cache/PackageKit/25/metadata/google-earth/packages/google-earth-stable-

Any help is appreciated. TIA.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2016-12-22 12:35:11 -0500

ed209 gravatar image

An alternative method would be to erase package google-earth and reinstall later after upgrade to F25.

edit flag offensive delete link more


this was my solution too after I encountered the above error. Worked.

thingummybob gravatar imagethingummybob ( 2016-12-23 06:01:50 -0500 )edit

did the same: uninstall, and reinstall after the upgrade.

love the Fedora 25!

Cosmin gravatar imageCosmin ( 2016-12-24 22:39:13 -0500 )edit

answered 2016-12-21 09:09:39 -0500

Hello, disable GPG check for google-earth. change gpgcheck=1 to 0 (zero) in the .repo file. /etc/yum.repos.d/google-earthwhatever.repo

edit flag offensive delete link more


Thanks Octavia. After setting gpgcheck=0, new error message is: "Error running transaction: file /usr/bin from install of google-earth-stable- conflicts with file from filesystem-3.2-37.fc24.x8664". I do not want to uninstall Google-earth: it is really hard to install anything in Linux - I'm new to it.

wawa gravatar imagewawa ( 2016-12-25 02:21:34 -0500 )edit

Question Tools


Asked: 2016-12-20 23:50:25 -0500

Seen: 308 times

Last updated: Dec 22 '16