Ask Your Question
0

Epel 7 updates for libgit2, python-pygit2 & libgit2-devel

asked 2016-12-19 10:06:27 -0500

haeac gravatar image

Hello,

It seems that whilst upgrading from 7.2 to 7.3, the libffi and python-cffi were upgraded but the libgit2, python-pygit2 & libgit2-devel packages from epel 7 didn't get upgraded. This is causing errors like the following to show up:

[WARNING ] /usr/lib64/python2.7/site-packages/cffi/model.py:526: UserWarning: 'gitcheckoutnotifyt' has no values explicitly defined; next version will refuse to guess which integer type it is meant to be (unsigned/signed, int/long) % self.getcname())

[WARNING ] /usr/lib64/python2.7/site-packages/cffi/model.py:526: UserWarning: 'gitmergetreeflagt' has no values explicitly defined; next version will refuse to guess which integer type it is meant to be (unsigned/signed, int/long) % self.getc_name())

It seems that version 0.24+ of the packages resolve this issue. Will libgit2, python-pygit2 & libgit2-devel be updated soon in epel 7? Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-12-21 15:06:43 -0500

CAI Qian gravatar image

Better to fix bugs against those packages in bugzilla asking for newer versions, so the packagers could interactive with your about the requests.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2016-12-19 10:06:27 -0500

Seen: 85 times

Last updated: Dec 19 '16