Ask Your Question
1

I can't login as root in fedora 17

asked 2013-01-01 20:32:04 -0500

dancallo gravatar image

When I logout as a regular user and attempt to login as root in Fedora 17, the password does not work and I continue to get "authentication failure" even though I know I'm using the right password. Does Fedora 17 allow one to login as root? If so, why is my password not working. I have used su passwd and changed the password for root but it still does not work.

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
1

answered 2013-01-02 12:52:13 -0500

Akshay gravatar image

updated 2013-01-02 12:53:02 -0500

root login on run level 5 is not enabled in Fedora 17 by default so you need to make some changes if you want to login as root in fc17, i guess its enabled in Fedora 18

edit flag offensive delete link more

Comments

'root' is a special user, whose privilege is only invoked when administering the local system. It isn't intended to be available for general use. If you are using a GUI program that requires root access, you will usually be prompted for a password. If you need to use a command line as root, open a terminal as your normal user, then use su or sudo.

randomuser gravatar imagerandomuser ( 2013-01-02 19:12:13 -0500 )edit

dancallo, you don't need a desktop environment for that...

randomuser gravatar imagerandomuser ( 2013-01-04 01:58:40 -0500 )edit

Dancello, I've been using various versions of RedHat and Fedora since 1998, and have used Fedora as my only OS for over six years. The only times I've ever needed to use a GUI as root were to find out if sound worked for root, as it wasn't working for my normal user. Yes, there are GUI programs that run as root, such as yumex, but I don't need to be logged in as root to use them. (They ask for the root password when needed.) What is it that you want to do in a GUI that must be done with you logged in as root?

sideburns gravatar imagesideburns ( 2013-06-08 15:31:34 -0500 )edit
0

answered 2013-01-01 21:11:33 -0500

jpilldev gravatar image

What Desktop interface do you use?, maybe the config files doesn't allow to login with root

edit flag offensive delete link more
0

answered 2013-01-03 06:42:01 -0500

ztank1013 gravatar image

I discourage the fashion of logging in as root and by default this is not allowed in Fedora 17 using gdm (graphical interface).
But if you want to change this behavior you will need to edit at least one PAM (Pluggable Authentication Module) file.
Edit this file: /etc/pam.d/gdm-password

vi /etc/pam.d/gdm-password

and comment the following line

#auth        required      pam_succeed_if.so user != root quiet

Adding a pound (#) sign at the beginning of the line will work. Logout and try logging in again using root account credentials.

edit flag offensive delete link more

Comments

@q2dg AFAIK root login from gdm is enabled by default in Fedora 18

Akshay gravatar imageAkshay ( 2013-01-03 22:25:48 -0500 )edit
0

answered 2013-06-07 09:22:25 -0500

maximus gravatar image

updated 2013-06-07 09:24:17 -0500

At Fedora 17 GUI login: I selected my username. At password prompt I picked on "Session..." and selected "KDE Plasma Workspace (failsafe session). It solved my problem. I hope that helps someone else.

edit flag offensive delete link more

Question Tools

3 followers

Stats

Asked: 2013-01-01 20:32:04 -0500

Seen: 26,295 times

Last updated: Jun 07 '13