Ask Your Question

How do I disable tracker in GNOME?

asked 2011-11-09 19:42:22 -0500

Rob Spanton gravatar image

updated 2017-01-13 15:24:06 -0500

mattdm gravatar image

I was having performance problems, and I discovered that tracker was churning through my filesystem. This is an infeasible task for it, as it contains an extremely large number of files.

How do I disable it?

edit retag flag offensive close merge delete


Looking for answers... please be aware that the method has changed since the question was asked and answered in 2011. Try hit the Sort by newest button below.

florian gravatar imageflorian ( 2018-07-16 09:46:48 -0500 )edit

12 Answers

Sort by » oldest newest most voted

answered 2018-07-16 09:42:23 -0500

florian gravatar image

updated 2018-09-24 09:49:44 -0500

as of 2018:

Looking for one simple command:

gsettings set org.freedesktop.Tracker.Miner.Files enable-monitors false

+1 for describing Gnome's GUI method described by @samtuke above/below.

edit flag offensive delete link more



this is the true answer

but please add to it

gsettings set org.freedesktop.Tracker.Miner.Files crawling-interval -2

according to source code should crawl would return false

alsadi gravatar imagealsadi ( 2018-08-28 02:18:51 -0500 )edit

For me on Cinnamon enable-monitors false wasn't enough and I managed to pacify it (back when tracker was endlessly rescanning and crashing on some files) with org.freedesktop.Tracker.Miner.Files ignored-files ['*']. After setting it there was one spike of cpu usage and then... peace ;)

ozeszty gravatar imageozeszty ( 2018-09-24 12:44:34 -0500 )edit

answered 2011-11-10 01:06:40 -0500

SoumyaC gravatar image

You can go ahead and uninstall tracker, but the only issue is that gnome-documents uses this library and expects the tracker deamon to run on the background. So via uninstalling tracker you will loose gnome-documents. (at least)

You can take a look at below command output, if u can do some good -

# tracker-preferences

Also searching about tracker I like to point you to below link -">Bug 613256

Above bug if you notice the last comment it states

See $HOME/.config/tracker/tracker-miner-fs.cfg and the key CrawlingInterval. If set to -1 crawling is disabled entirely.

Hopefully the above details help you.

edit flag offensive delete link more


Ya , checking in later I found many of the applications are using tracker totem is one of them.

SoumyaC gravatar imageSoumyaC ( 2011-11-10 07:56:18 -0500 )edit

answered 2011-11-10 02:47:39 -0500

lzap gravatar image

updated 2013-11-14 09:41:38 -0500

In GNOME 3.2 there was no user interface so the only way was to copy the following files


to your .config/autostart directory and edit all of them setting this value to false:


You can also delete .cache/tracker directory - this is where Tracker stores the index. It can be quite huge (1 GiG for me). Then kill all tracker processes or restart your computer.

Newer GNOME 3 version support that.

edit flag offensive delete link more


You can do the same using UI - run gnome-session-properties in a terminal and unclick all three items there. Restart.

lzap gravatar imagelzap ( 2011-11-19 16:08:54 -0500 )edit

answered 2011-11-19 05:00:36 -0500

Nebojša gravatar image

There is an interface: gnome-session-properties Just run it in disable unneeded services

edit flag offensive delete link more

answered 2012-05-23 06:04:33 -0500

jde gravatar image

tracker-control is also handy in a session .. kill and remove the databases with:

tracker-control -r

then check the status

tracker-control -S
edit flag offensive delete link more



With tracker-preferences you can change, when tracker is started. Best idea is to start it only, when the computer is idle. See this guide

erik gravatar imageerik ( 2015-03-04 10:48:42 -0500 )edit

Please edit your reply because tracker-control command has been removed and now tracker tool has these options.

Replacement commands for one you listed in your reply are now:

tracker reset
tracker status
valentt gravatar imagevalentt ( 2016-06-22 01:54:10 -0500 )edit

answered 2014-05-16 09:32:33 -0500

produnis gravatar image

as of 2014, try command:


a gui pops up and you can uncheck anything you like

edit flag offensive delete link more



On a normal installation of Fedora 22, you have to install tracker-preferences prior to starting it. ( dnf install tracker-preferences )

mithrial gravatar imagemithrial ( 2015-08-31 13:32:34 -0500 )edit

as of 2018, this is not the correct answer anymore.

florian gravatar imageflorian ( 2018-07-16 09:43:14 -0500 )edit

answered 2014-08-16 01:07:53 -0500

oxtan gravatar image

updated 2014-08-16 01:13:00 -0500

in the end, after ahving tried all this I just got rid of it by disabling the dbus scripts that launch tracker in /usr/share/dbus-1/services. Just remove or rename the files in there with tracker1 in it.

edit flag offensive delete link more

answered 2014-09-29 16:08:12 -0500

coverturtle gravatar image

updated 2014-09-29 21:16:16 -0500

[See my Post Script at the bottom if you have read this before.] First of all, I am running Fedora 20 on a desktop system with the development features and gnome 3. It wasn't long after I began that I noticed lack of keyboard response bordering on no keyboard at all so I looked and found that my disk light was on continuously. Realizing from past experience that this is the tracker-miner, I looked for it and found it in the system monitor.

I haven't seen any disadvantage to simply (as root) removing permissions from the executables in /bin/track* and /usr/libexec/track* but a subsequent update did reverse my actions. That does not mean that there were or are disadvantages although all the applications I used (Firefox, Thunderbird, Libre Office and a vew utilities) don't seem to suffer. YMMV.

Recently I decided to try another tactic and apparently I have succeeded in reducing the hold on my system. I used several changes and then restored the correct permissions to the executables.

(1.) I ran "gnome-session-properties" from a terminal which did not show tracker and so was dismissed. No help there.

(2.) I ran "tracker-preferences" from a terminal which is more helpful, but after a trial with my mods, went back to the defaults. See the Post Script. **

(3.) I also changed these files: ~/.config/autostart/tracker* but primarily tracker-miner-fs.desktop and tracker-store.desktop: In tracker-miner-fs.desktop, I removed the foreign language names and added some options to the executable line:

  Exec="/usr/libexec/tracker-miner-fs --no-daemon --disable-miner=Applications --disable-miner=Userguides"

 In tracker-store.desktop, I also removed the foreign language names and added an option to the executable:

 Exec="/usr/libexec/tracker-store --low-memory"

 It should not matter how much memory I actually have (2GB) or if I add more.

(4.) Finally, I needed to do a hard-reset of tracker and restart it as root which went like this:

 sudo tracker-control -t  # properly terminates tracker processes without damaging any data (hopefully)

 sudo tracker-control -r  # kills any remaining processes and removes the databases

 sudo tracker-control --start # starts miner processes and tracker-store

Perhaps not all of #4 needs to be run as root, but it's better to be safe.

So far, (just a few hours) I'm quite pleased again have control of my computer!

Please, if you try this, post here if it does not work for you. Remember, this is for a gnome (3) system. If you favor kde, there's a different path for you to follow.

**Post Script: I did have a problem with yumex for some reason and I could not remove it. Except for telling tracker that I have low memory - which seems to help considerably, by the way - I went back to the defaults in tracker-preferences. Rebooting seems to have helped with not being able to use yumex - I also removed and re-installed yumex. Tracker seems to behave now with the "low memory" option per above. There is one tracker-childtask, tracker-store is ... (more)

edit flag offensive delete link more

answered 2017-12-22 03:48:38 -0500

you kill the tracker process with this script.

edit flag offensive delete link more

answered 2018-02-09 06:05:24 -0500

samtuke gravatar image

None of the existing answers work on Fedora 27, Gnome 3.26.2 (the tracker-related GUI tools are not available in repositories).

It appears that tracker can be disabled by simply going to Settings -> Search -> [Window bar] Switch Off.

edit flag offensive delete link more


dconf-editor org > freedesktop > tracker > miner > files

ilya_ gravatar imageilya_ ( 2018-02-16 11:16:12 -0500 )edit

Question Tools



Asked: 2011-11-09 19:42:22 -0500

Seen: 140,630 times

Last updated: Jan 22 '19