Ask Your Question
0

Is beeping broken in f17?

asked 2012-08-13 10:13:46 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

beep used to work before I upgraded to f17. I have uncommented the last line in /etc/modprobe.d/beep.conf; lsmod shows pcspkr is loaded and the beep command works. However vim does not beep, nor does printf '\a'.

Any ideas?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-02-06 12:38:33 -0500

Thanks to someone at Red Hat answering my (same) question, I discovered that the XKB extensions require a different tool to view/tweak settings rather than (just?) xset. Install xkbset ("yum install xkbset") and run "xkbset q" to view your settings and, most importantly, "xkbset b" to enable the Audible Bell. I don't use Gnome/KDE, so I'm not sure what your best method is, but I run "User Script" (which invokes my old-school .xsession file) so I put that command ("xkbset b") in my .xsession - which solved the problem for me. I expect there's an equivalent for Gnome/KDE, etc. - so you'll need to do your own homework there.

I hope that helps,

Adam

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-08-13 10:13:46 -0500

Seen: 240 times

Last updated: Feb 06 '13