Ask Your Question
2

I can't login after upgrading to fedora 25

asked 2016-12-08 15:36:28 -0500

MohamedAmin gravatar image

After upgrading the system using dnf method, I can't login to my account.. Everytime I try to login as usual, the system redisplays the login screen.. I've tried also to login from my root account and I can't.. So I can't login to my account anymore.. I've searched for solution but I found nothing.. this guy probably have the same problem as me.. http://forums.fedoraforum.org/showthr...

edit retag flag offensive close merge delete

Comments

did you try to login in from a pseudo terminal? -> use ctrl+alt+f2 to access it

baoboa gravatar imagebaoboa ( 2016-12-08 15:43:52 -0500 )edit

I have tried that.. but when I try to login from the login screen I can't.. I've tried also to login to an other desktop environment from an other user but I can't..

MohamedAmin gravatar imageMohamedAmin ( 2016-12-08 16:58:17 -0500 )edit

5 Answers

Sort by ยป oldest newest most voted
1

answered 2016-12-09 09:30:31 -0500

MohamedAmin gravatar image

And finally the problem has been solved !.. I think a conflict between packages caused this problem.. When I typed sudo dnf repoquery --duplicated I founded many duplicated packages from the old and the new releases.. So I concluded that the upgrade has been interrupted.. after typing:

sudo dnf distro-sync

an error due to a conflict between dnf , systemd appeared.. So I searched for duplicate packages rpm -qa | grep <package> then I deleted these packages : dnf-1.1.10-1.fc24.noarch systemd-229-16.fc24.x86_64 systemd-udev-229-16.fc24.x86_64 systemd-container-229-16.fc24.x86_64 then completed the upgrade peacefully with sudo dnf distro-sync

edit flag offensive delete link more
0

answered 2017-11-09 14:14:00 -0500

cpa30 gravatar image

In my case the problem was with my .bashrc file. I installed tmux and wanted it to fire when a new instance of the terminal is launched so I put this inside the .bashrc file

if command -v tmux>/dev/null; then
    [[ ! TERM =~ screen ]] && [ -z $TMUX ] && exec tmux
fi

By commenting it out I was able to log-in into GNOME again.

edit flag offensive delete link more
0

answered 2017-10-29 19:02:41 -0500

mkungla gravatar image

I had similar issue multiple cases and always was the reason that I had compiled or installed proprietary graphics driver from src or unofficial repo which caused upon upgrade initramfs not to rebuild correctly. Especially in case of kernel update.

Solution was to simply login via pseudo terminal ctrl+alt+f2

uninstall and reinstall graphics driver based on instruction depending of driver installed and reboot which always have worked out and solved the issue for me.

Even if that is not solution for problem you had I hope that it helps someone facing similar problem I had!

edit flag offensive delete link more
0

answered 2017-03-07 19:13:19 -0500

This happened to me a few weeks after upgrading. Switching back to GNOME on Xorg let me login in again.

edit flag offensive delete link more
0

answered 2017-07-01 18:10:14 -0500

balek gravatar image

This happened to me today. But a can't log in on gnome, gnome classic or even gnome on Xorg. The finger swipe option available on Lenovo T540p also does not work. After switching to the terminal by using alt+ctl+F2 I can log in. A made all updates but that did not solve the problem. Could anyone please tell my how to debug this problem further.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-12-08 15:36:28 -0500

Seen: 5,245 times

Last updated: Oct 29 '17