system wide proxy for kde on fedora-18

asked 2013-01-30 06:54:18 -0500

nullpointer9811 gravatar image

updated 2013-01-30 07:32:25 -0500

Jomoos gravatar image

I am trying to set up a system wide proxy in fedora 18.

When i do echo $http_proxy (or sudo echo $http_proxy) i get http://x.x.x.x:port. If I set up firefox to use system settings it just doesn't work. if i use the IP in firefox it works ok. Its the same ip but for some reason firefox and yum won't pick it up. i tried adding it in ~/bashrc, ~/bash_profile (both my user and root) and in /etc/profile. I also trying setting it up on KDE proxy settings. It just doesn't work. Firefox and yum won't pick it up. Is there any simple way to set it up in one place rather than configuring every single app?

edit retag flag offensive close merge delete