Fedora 25 fails to boot on second time with akmod-nvidia

asked 2016-12-04 17:05:26 -0500

tigrebleu gravatar image

I face a headache regarding Nvidia driver installation on my freshly installed F25. (I own a GTX 660 card that freezes all the time with Nouveau)

I installed from RPM Fusion akmod-nvidia and kmod-nvidia. After the install I have this:

# dnf list installed | grep nvidia
akmod-nvidia.x86_64                   1:375.20-1.fc25           @rpmfusion-nonfree-updates
kmod-nvidia.x86_64                    1:375.20-1.fc25           @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64            1:375.20-1.fc25           @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64    1:375.20-1.fc25           @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.i686         1:375.20-1.fc25           @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64       1:375.20-1.fc25           @rpmfusion-nonfree-updates

When I reboot, it works. it takes some time as akmod is building the kernel module. Once rebooted, I have this:

# dnf list installed | grep nvidia
akmod-nvidia.x86_64                   1:375.20-1.fc25           @rpmfusion-nonfree-updates
kmod-nvidia.x86_64                    1:375.20-1.fc25           @rpmfusion-nonfree-updates
kmod-nvidia-4.8.10-300.fc25.x86_64.x86_64
xorg-x11-drv-nvidia.x86_64            1:375.20-1.fc25           @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64    1:375.20-1.fc25           @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.i686         1:375.20-1.fc25           @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64       1:375.20-1.fc25           @rpmfusion-nonfree-updates

We can see that there are now 2 packages kmod-nvidia.

When I reboot a second time, the startup fails right after grub.

I need to boot on another kernel, uninstall the kmod-nvidia-4.8.10-300.fc25.x86_64.x86_64 generated package and then I am able to reboot with the current kernel.

Any clue on what's going on?

edit retag flag offensive close merge delete