Ask Your Question
1

Hawaii shell doesn't work

asked 2016-12-04 10:43:50 -0500

kusinagi gravatar image

updated 2016-12-13 10:59:47 -0500

The Hawaii desktop stops working after i barley start. I get past the disk encryption and the start stops both mouse and keyboards don't even do anything. I did 4 different installs. I installed fedora 25 on all 4 of my computers each one is different. Amd 3 core phenom Amd 4 gb ddr3 grafix card does not want to use my 4 keyboards. Hp probook4440s keyboard and track-pad doesn't work. Amd fx 8 core 8gb ddr5 grafix card. Intel pentium 4 core with a nvidia 2gb ddr3. All of these computers will not do anything past the load up the sign in screen and have to do a hard reboot to try again. Is there something im doing wrong i love all the fedora and other distros shell but this is not working right at all. any ideas to help me with this? I used a usb netinstaller and selected the hawaii desktop. Then it would load to the to the sign in screen and then all function of keyboards and mouse/track-pads do not respond.

edit retag flag offensive close merge delete

Comments

1

Sorry, I'm confused. Could you edit your question to help walk us through the steps you took and where things went wrong?

  • You've installed Fedora 25 on four different machines. Did you use the regular Live Workstation image, or one of the Fedora Spins, or the net installer? Were there any error messages during installation?
  • Did you start with the default GNOME and then add Hawaii Desktop, or did you start with Hawaii via net install?
  • What exactly do you see on screen when it stops responding? The Fedora logo loading screen, a bunch of text for startup messages, or the login screen?
terrycloth gravatar imageterrycloth ( 2016-12-11 23:06:51 -0500 )edit

I used a usb netinstaller and selected the hawaii desktop. Then it would load to the to the sign in screen and then all function of keyboards and mouse/track-pads do not respond.

kusinagi gravatar imagekusinagi ( 2016-12-13 11:00:11 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2016-12-13 19:42:37 -0500

terrycloth gravatar image

I was having the same issue as you, except that I'd installed Fedora 25 Hawaii as a virtual machine instead of a "bare metal" installation. I'd thought at first that maybe it was some issue specific to virtualization, but turns out there's an open bug report about this. To sum up, the Fedora net installer's Hawaii packaging group does not include the xorg-x11-drv-evdev package, which we need.

You can do one of two things.

Option 1: Boot into text mode and install the missing package

If you still have Fedora installed with Hawaii as the only graphical shell, you will need to boot into text mode --- at the very beginning of the boot process, in the GRUB menu, hit E to edit the boot options. Scroll down, using the arrow keys, to the line starting with "linux16 /vmlinuz..." At the end of the line (after the part that says "...rhgb quiet") type the number 3. This tells GRUB to boot into runlevel 3 which is a simple text mode where you can type commands. Now hit Ctrl-X to finish booting.

When everything has finished loading, you'll see a login prompt. Type your username and password. Then run sudo dnf install xorg-x11-drv-evdev

When that's done, you can reboot (by typing sudo shutdown --reboot now) and everything will work as it should... with one small exception. For some reason, the SDDM login screen defaults to logging you into Openbox instead of Hawaii. You'll have to select "Hawaii (Wayland)" from the Session drop-down menu in the top-left of the screen. In my experience, it takes a few seconds to respond after entering my password to login, but otherwise everything should be fine now.

Option 2: Start over with a different graphical shell, then add Hawaii

You've already tried reinstalling a bunch of times already, so I'd understand if you didn't want to start over yet again. However, if you aren't so comfortable typing command lines, this may be the easier option: Reinstall Fedora and pick one of the other graphical shells (GNOME, Plasma Workspaces, Cinnamon...). This may also be a better option for you since Hawaii is still very new, and you may or may not want to use it as your only shell just yet.

Once Fedora is reinstalled, you can add Hawaii from the command line --- sudo dnf install "@*hawaii*" will get all Hawaii package subgroups --- or you can use yumex-dnf, a graphical package manager with a nice enough GUI which will let you do more than GNOME Software can. You'll need to install yumex-dnf first. Then launch it, click on Groups at the top, then in the left pane click on all the check boxes under Hawaii Desktop. Then install by clicking on the gears button in the top-right (which will say "Apply pending actions" when you hover over it).

Next time you reboot, Hawaii should be available. At the login screen, just remember to select Hawaii ... (more)

edit flag offensive delete link more

Comments

I tried the first solution and was rebuffed with the message, "You aren't in the sudoers file. This incident will be reported."

joring gravatar imagejoring ( 2017-05-31 11:40:23 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2016-12-04 10:42:48 -0500

Seen: 1,322 times

Last updated: Dec 13 '16