Ask Your Question
1

Fedora updating issue (F24 to F25)

asked 2016-12-04 09:45:18 -0500

warlock20 gravatar image

updated 2016-12-05 05:03:49 -0500

While trying to update from F24 to F25, i ran into following error

Error: The operation would result in removing the following protected packages: systemd, dnf.

The following is the DNF log message:

Dec 05 11:55:40 DEBUG --> Finished dependency resolution
Dec 05 11:55:40 DDEBUG timer: depsolve: 867 ms
Dec 05 11:55:40 INFO Dependencies resolved.
Dec 05 11:55:40 DDEBUG Cleaning up.
Dec 05 11:55:40 SUBDEBUG 
Traceback (most recent call last):
  File "/usr/lib/python3.5/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.5/site-packages/dnf/cli/main.py", line 120, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python3.5/site-packages/dnf/cli/main.py", line 142, in resolving
    base._plugins.run_resolved()
  File "/usr/lib/python3.5/site-packages/dnf/plugin.py", line 82, in fn
    dnf.util.mapall(operator.methodcaller(method), self.plugins)
  File "/usr/lib/python3.5/site-packages/dnf/util.py", line 183, in mapall
    return list(map(fn, *seq))
  File "/usr/lib/python3.5/site-packages/dnf-plugins/protected_packages.py", line 76, in resolved
    raise dnf.exceptions.Error(THREATENED_MSG % ', '.join(threatened))
dnf.exceptions.Error: The operation would result in removing the following protected packages: dnf, systemd.
Dec 05 11:55:40 CRITICAL Error: The operation would result in removing the following protected packages: dnf, systemd.

I also tried to remove python3 and got similar error,

Error: The operation would result in removing the following protected packages: dnf.

edit retag flag offensive close merge delete

Comments

Please clarify what you mean by "trying to update" or we can't help. Please tell us what command you are running in order to "try it".

lovepump gravatar imagelovepump ( 2016-12-04 20:09:22 -0500 )edit

sorry, i tired to upgrade from F24 to F25 using the command sudo dnf system-upgrade download --releasever=25

Then i ran into this error.

warlock20 gravatar imagewarlock20 ( 2016-12-05 04:08:59 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-12-05 05:41:38 -0500

warlock20 gravatar image

updated 2016-12-05 08:16:33 -0500

@lovepump its an issues with python3-dnf-plugins-core package ( https://bugzilla.redhat.com/show_bug.... ). Did you have any idea about it? I saw similar issues with others whil upgrading older versions. But now i run into new error

Error: Transaction check error:
  file /usr/lib/node_modules/npm/node_modules/node-gyp from install of nodejs-1:4.6.2-1nodesource.fc24.x86_64 conflicts with file from package nodejs-1:4.6.1-6.fc24.x86_64

Some issues with node_modules..

I removed the npm files and now it works fine...

But why? I still don't know.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-12-04 09:45:18 -0500

Seen: 330 times

Last updated: Dec 05 '16