Ask Your Question
3

Fedora doesn't boot in X11 [closed]

asked 2016-12-04 07:55:45 -0500

RadonRose gravatar image

updated 2016-12-09 10:31:07 -0500

Fedora stops booting X11 in Started User Manager for UID 42, after updating gnome-shell, gnome-session, gnome-session-wayland, gnome-sessions-xsession, xorg-x11-drv-libinput and other stuff, on December 2

Wayland boots normally, but has other issues with the graphics and also is slower. I had uncommented the waylandEnable line to boot in X11, but now I made it a comment again and boot in Wayland.

Are there any other ways to start the Gnome Session in X11? Should I perhaps remove something NVidia related? I have seen NVidia drives causing the opposite problem in earlier Fedora editions (Wayland stopping at the same point during boot, but X11 working normally)

Acer Aspire 5732z

Kernel: 4.8.10-300.fc25.x86_64 Updated to: 4.8.11-300.fc25.x86_64

VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)

Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by RadonRose
close date 2016-12-09 23:48:33.939212

Comments

Facing same problem with Lenovo T400 think pad. Neither Wayland nor XOrg works for me.

I even installed KDM & LightDM to login but cannot get Desktop.

Nirmal gravatar imageNirmal ( 2016-12-04 23:49:35 -0500 )edit

I have the same problem that Wayland(Gnome) works but Xorg and Gnome classic does not. I have a Dell XPS m1530 32 bit computer with Nvidia. I dont know how to check what display driver it is using either. One of them has a black screen with an X and the other has a grey screen that freezes

Don gravatar imageDon ( 2016-12-05 09:54:32 -0500 )edit

I just had an update of Kernal 4.8.8.11 and Xorg and Classic still does not work and I'm continuing to use Wayland. The failed to load Kernal module message is gone though.

Don gravatar imageDon ( 2016-12-06 15:49:31 -0500 )edit

Gnome Xorg boots with black screen white desktop icons and X for cursor. Cannot access programs or click icons. Problem started with update to kernel 4.8.10-300 and remained with update to 4.8.11-300. Wayland works. Dell 7510, Nvidia GM107GLM (Quadro M1000M), system does not have an intel graphics chip.

stevel gravatar imagestevel ( 2016-12-07 01:02:47 -0500 )edit

Today Xorg and Classic are working normally. I have my Icons back, Yeah

Don gravatar imageDon ( 2016-12-09 17:52:47 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-12-09 23:47:45 -0500

RadonRose gravatar image

Fixed after update on December 10. These were updated, amongst others:

gnome-software-3.22.3-1.fc25.x86_64

kernel-4.8.12-300.fc25.x86_64

kernel-core-4.8.12-300.fc25.x86_64

kernel-modules-4.8.12-300.fc25.x86_64

kernel-modules-extra-4.8.12-300.fc25.x86_64

xorg-x11-drv-wacom-0.33.99.1-1.fc25.x86_64

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2016-12-04 07:44:06 -0500

Seen: 497 times

Last updated: Dec 09 '16