Ask Your Question
0

Steam freezing with Fedora 25(probably GPU issues)

asked 2016-12-03 14:34:13 -0500

Dekken201 gravatar image

updated 2016-12-04 08:48:44 -0500

Hello! I'm having a bit of a problem. My workstation is an old Vaio notebook, with AMD CPU and a ATI Radeon HD 4200 for GPU. I never expected it to play anything, but since I've bought it, I've used Windows and it served me just fine. Two years ago I started using Linux, and I already knew I had to give up some hobbies if I were to use it 100%. Started using exclusively Fedora, at that time, in the 23rd version, after some months of distro hopping. Anyway, I experimented a lot, and after some time, learned Steam had a Linux version, and I started using it. It was pretty good, I could play some low requirements games. I upgraded to F24 and it kept on great, no problems at all. I thought maybe I could get a boost in some games if I got the proprietary drivers for my GPU, but after some fiddling and breaking my DE, I gave up and kept using mesa. Even after all that, I could still play games just fine. But Fedora 25 came and since it was some time since I cleaned my HD, I wiped everything and made a fresh Fedora 25 install. Everything's great, but I believe something's wrong with my GPU driver or something. Whenever I put some strain in it, it freezes whatever program I'm using. For example, playing games in Steam, I start playing something, or just browsing the client, it randomly freezes and I have to SIGKILL the process and open it again. Some rare times, when watching something in Netflix, it freezes the same way. I believe it probably has something to do with GPU drivers. Maybe because of the version update? How could I go on to solve this? Using an older driver? Is there a easy way to use proprietary graphics? Many many thanks in advance

Edit: I'm using Cinnamon.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-12-03 15:42:23 -0500

Benjamin Doron gravatar image

Fedora 25 uses the Wayland window manager by default. Mesa supports it, but perhaps Steam does not. You can wait until Steam updates, but they might not for a while. Provided that you are using GDM, navigate to /etc/gdm/custom.conf and edit it to say

[daemon]
WaylandEnable=false

You could also try updating everything, but this should be done by default. I'm not sure if this answers your question.

edit flag offensive delete link more

Comments

I'm using Cinnamon. I also generally update everything as soon as I can. The problem is that I don't even know what's going on. I tried rolling back the kernel, still freezes. Sometimes it freezes just browsing the client, sometimes after 15 minutes of playing something.

Dekken201 gravatar imageDekken201 ( 2016-12-04 08:48:11 -0500 )edit

Question Tools

Stats

Asked: 2016-12-03 14:34:13 -0500

Seen: 486 times

Last updated: Dec 04 '16