Ask Your Question
3

Screen turns off during Fedora 25 boot

asked 2016-12-02 23:13:30 -0500

ivarhill gravatar image

I got an issue where booting into a fresh Fedora 25 install, as soon as I've chosen Fedora in grub the screen turns off. Booting with nomodeset works, but (I assume because it uses the vesa driver) the resolution is low and performance suffers. Using recovery mode, interestingly enough, boots into a native resolution.

I do not wish to use proprietary drivers, mainly because this is meant as a somewhat portable setup and hardware may change, so that would not be very flexible. I'm using an nVidia GTX970 GPU and a monitor connected with DVI.

I tried making a liveUSB drive just to see if there's a difference and it fails in the exact same way.

Does anyone have any idea of how I can make Fedora work on this setup? (I assume it's currently trying, and failing, to use the noveau drivers?) - if whatever is different booting into recovery mode which makes it work, could be applied to normal boot, I assume that would work well but I have no idea what that is.

Appreciate any help :)

edit retag flag offensive close merge delete

Comments

How does grub.cfg "load in video stuff" for "recovery mode"? (sudo more /boot/efi/EFI/fedora/grub.cfg) Your grub.cfg file may do some different things for the rescue boot menu entry than it does for your normal fedora menu entry. Any differences? If not, check the kernel command lines for rescue and normal entries - any video related differences?

lovepump gravatar imagelovepump ( 2016-12-04 20:58:10 -0500 )edit

try "cat /proc/cmdline" to check (currently running) kernel command line if you can't pick it out with "more grub.cfg"

lovepump gravatar imagelovepump ( 2016-12-04 21:23:35 -0500 )edit

I also have a gtx970 and have the same problem, monitor goes off, because of no video signal, during live install from either usb or cd. I can install f24 just fine, and I have tried every spin available, and also f25 workstation. Please fix this. Can not Ctrl-Alt-F2 to a screen to run any commands. Complete lock out.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2016-12-06 09:27:38 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-12-07 14:29:42 -0500

SteveEbey73701 gravatar image

updated 2017-03-25 17:03:27 -0500

Ok, so far, what I have found, if you catch the initial boot, and hit E, put nomodeset ahead of quiet you can get in, and install it. When it reboots, it leaves the nomodeset as the parameter to boot up. Now comes the fun part. You can run, at 1024x768 but if you have Nvidia graphics cards, YOU CAN NOT install the drivers, as F25 WILL NOT WORK. I have spent 3 days, testing various guides and fixes, that allege to solve the video problem, which according to journalctl output, is a failure in OpenGL to create textures, so the driver aborts and you can use Ctrl-alt-f2 to get to a terminal and shutdown. I will be using F24 for now, to see if I can at least get Nvidia to work. I will continue to post to this thread, with additional progress, if any is made. If someone has other solutions to test with F25 I would be welcome to try them out. So far, I am not impressed with F25.

Update: Solution found.

The following steps, taken from another guide and updated for F25 worked for me.

These steps assume you are up and running in 1024x768 and have downloaded all the updates. DO NOT DO THIS IF YOU HAVE UPDATES PENDING. Go to www.nvidia.com and download the latest Linux driver for your video card. The steps outlined here, assume a newer card, made after 2010 that will support the xorg server 1.19. If you have an older card, then you will need to disable Xorg server. I do not show how to do that, because I did not need to. Please read all the steps, before beginning, so that you do not have an oops moment and have to start completely over.

Update again:My apologies, I left a critical step out. after sudo -i

start terminal
sudo -i
dracut --omit-drivers nouveau /boot/initramfs-$(uname -r).img $(uname -r) --force
systemctl set-default multi-user.target (boots into a text only mode)
reboot
login as root
dnf install kernel-devel-$(uname -r) gcc dkms acpid
dnf install vdpauinfo libva-vdpau-driver libva-utils
bash /dirofsavedfile/NVIDIA-Linux-x86_64-...run (driver version number in place of ..)
Accept license, say yes to DKMS and 32 bit library installation. If running in secure boot EFI, you will be possibly need to make a digital key.  I do not fully understand that procedure, so I disabled secure boot in my bios and did not have to do that step. Also say yes when you get prompted to make an Xconfig file.  If you want to activate fan control features, after the driver is installed use nvidia-xconfig --cool-bits=12 and that will let you use nvidia-settings to adjust the fan controls, and also change the performance settings.
systemctl set-default graphical.target
reboot

Enjoy F25 at the best resolution your monitor has. I hope this helps others and saves a ton of time for everyone.

edit flag offensive delete link more

Comments

Just commenting to say that this indeed worked perfectly for me and my F25 + NVIDIA GTX 970 setup! Thank you. I'm baffled that NVIDIA graphics cards simply don't work well out of the box with such a major distro and new release?? I'm not really asking for anything proprietary here even if that looks like the solution this time -- just looking to be able to pick desktop resolutions.

Jugalator gravatar imageJugalator ( 2017-01-07 14:37:54 -0500 )edit

I take it you're using UEFI? When I first installed F25 with a GTX 970 using UEFI, I also was given the single display option of 1024x768. I got around it by switching to MBR, which gave me the 1920x1080 option I wanted. However, installing the Nvidia driver this way seems not to work with MBR. At first, it came up complaining about nouveau, so I added nouveau.modeset=0 to the grub line and ran "echo 'blacklist nouveau' >> /etc/modprobe.d/disable-nouveau.conf". That got rid of the complaining but only produced a gray screen with no login prompt.

kankaw gravatar imagekankaw ( 2017-03-25 14:10:00 -0500 )edit

@kankaw, I am using MBR, and i used dracut to remove nouveau. I have not used any of the other things you mentioned, as they did not work for me, what I posted here, works for my setup, MBR and gives me the max resolution my monitor supports of 1680x1050. it also AUTOMATICALLY builds new driver modules, when kernel updates are installed. The only thing that may be needed, is to run the removal and reinstall if the opengl drivers get updates. dkms does not check dependencies except during the first build, so if a opengl library is changed, that breaks the driver.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-03-25 16:54:51 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2016-12-02 23:13:30 -0500

Seen: 3,276 times

Last updated: Mar 25 '17