Ask Your Question
2

How to make GNOME 3 hibernate from timeout using pm-hibernate

asked 2013-01-12 00:28:52 -0500

SetJmp gravatar image

I am running Fedora 17 with GNOME 3 as my desktop, and have set up the machine to hibernate after idle for 1 hour. However, instead of switching off the machine appears to be on with the fan running.

When I run pm-hibernate from the command line, I get the expected hibernate behavior. Also, when I run systemctl hibernate the system hibernates correctly.

The KDE4 desktop hibernates correctly after the timeout occurs so I am using this as a work around. However, I would like to switch back to GNOME since I am used to the keyboard shortcuts.

I believe that the mechanism GNOME 3 is using to initiate hibernate is problematic. Where can I manually inspect what GNOME 3 is executing to accomplish the hibernate? And how can I modify it to run pm-hibernate as I do successfully from the command line?

Thanks,

SetJmp

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-02-03 09:30:54 -0500

rootameen gravatar image

I got the same issue, have you got any solutions for it?

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2013-01-12 00:28:52 -0500

Seen: 388 times

Last updated: Feb 03 '13