Ask Your Question

How do I get a working graphical desktop on F25 Server Edition?

asked 2016-11-25 21:57:10 -0500

ykill gravatar image

I would like to install fedora-server and still have a graphical desktop. Starting with fedora 25 server edition, I tried including extra software packages within the installer. I afterwards went in and tried groupinstalling fedora-workstation. However, there is no X or wayland happening. Will I have to do some actual work picking out packages, or do I simply need to mess around with systemd?

edit retag flag offensive close merge delete


dnf grouplist then pick up your preferred DE and install it with dnf groupinstall "YOUR_DE_GROUP_NAME"

fcomida gravatar imagefcomida ( 2016-11-26 06:52:54 -0500 )edit

@fcomida I did try that, but afterwards when I changed to the, it wouldn't go, even marking it as default. See my answer below, and thank you!

ykill gravatar imageykill ( 2016-11-26 07:53:49 -0500 )edit

startx from a terminal should launch your DE under X (GNOME since you groupinstalled fedora-workstation), i don't know how to launch a wayland session from the terminal. Try that and look at any errors, look at your logs too afterwards.

fcomida gravatar imagefcomida ( 2016-11-26 08:12:42 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2016-11-26 08:09:01 -0500

ykill gravatar image

I solved this myself, and here's what I did:

First, use the graphical installer for fedora25 server. Then install things as @fcomida suggested

# sudo dnf groupinstall "Development and Creative Workstation" gnome LibreOffice

This worked. I had thought I could simply install the group Fedora Workstation after installing server edition, but it didn't work for me. I added gnome for good measure, and LibreOffice since I'll install that anyway.

Immediately after this, I was able to go to and gdm started. I can also use cockpit to learn about server stuff. I set as default, and now I have my graphical desktop running on my "server!"

edit flag offensive delete link more

answered 2016-11-25 22:43:54 -0500

porfiriopaiz gravatar image

First of all install GNOME Shell Desktop Environment:
su -c 'dnf group install workstation-product-environment'

Then, you will have to set Graphical Login as Default:
su -c 'systemctl set-default'

And also you might have to enable gdm.service:
su -c 'systemctl enable gdm.service'

Hope this help.

edit flag offensive delete link more


That's what I was looking for: "workstation-product-environment." I haven't tested it, but this is probably correct. I had already tried your second and third lines, without success.

ykill gravatar imageykill ( 2016-11-28 22:12:25 -0500 )edit

answered 2017-09-05 06:43:14 -0500

tEcH gravatar image
edit flag offensive delete link more

Question Tools

1 follower


Asked: 2016-11-25 21:57:10 -0500

Seen: 21,013 times

Last updated: Nov 26 '16