Super-key Lock in Fedora 24/25

asked 2016-11-25 17:40:19 -0500

e-inquirer gravatar image

updated 2016-11-26 00:11:43 -0500

When switching workspaces via the (laptop) keyboard shortcuts:

  • Super + PgDn (Super + Fn + Arrow Down)
  • Super + PgUp (Super + Fn + Arrow Up)

The 'Super' key seems to lock/remain in a perpetual "ON" state. This results in all keys acting as if they are being pressed in tandem with the 'Super' key (e.g. typing 'a' brings up the Applications dash, left mouse/trackpad click will move a window, etc.). The only way to exit out of this seems to be to depress the 'Fn' and 'Super' keys together multiple times.

There also seems to be a sporadic issue with the 'Ctrl' key acting as if it's being pressed in conjunction with the 'Tab' key, and locking in this state.

Has anyone else experienced these issues, and if so, have they discovered a solution?

System info:

Lenovo Ideapad 14
Linux version 4.8.8-300.fc25.x86_64 
Fedora: 24/25, 64-bit
Gnome: Version 3.22.1

Thank you

edit retag flag offensive close merge delete

Comments

I am having the same issue. Still trying to see what triggers the problem.

masonwr gravatar imagemasonwr ( 2016-12-14 22:20:39 -0500 )edit

Same problem here on a Lenovo Ideapad 310s FN+WinKey in my case + up/down a few times and "a" or "s" or arrow-keys are no longer usable as the super-key seems stuck but it isnt. Logging out and in again helps a while. Latest Fedora 25 with current updates. This bug seems to be around for 10 years now ... ( https://ubuntuforums.org/showthread.p... )

moe120 gravatar imagemoe120 ( 2017-07-07 02:26:34 -0500 )edit