Ask Your Question
1

Cannot mount partition at startup

asked 2016-11-24 01:44:03 -0500

thanos gravatar image

I've enabled "mount at startup" for my partition at gnome-disk-utility as shown in the screenshot: http://imgur.com/a/u55jz

But on reboot, the partition is not mounted. The ouptut of systemctl status "mnt-5b989865\x2ddae6\x2d4f39\x2da5aa\x2d59b59f5f0ebd.mount" is this: http://pastebin.com/dW2gPfdz

If I change it to Identify As UUID and I mount it at /run/media/thanos/UbuntuMateHome then the problem still remains. How can I fix it?

P.S. First time I use fedora. I am an Ubuntu and Manjaro user and at both distros mount at startup works out of the box, so first time I see this problem.

edit retag flag offensive close merge delete

Comments

In order for you to mount a partition, the mount point must already exist. Does it? (When a removable device gets mounted automatically, the mount point gets created before the system is told to mount the drive.)

sideburns gravatar imagesideburns ( 2016-11-24 02:16:45 -0500 )edit
1

@sideburns In all other distributions that I have used, it works without doing any extra step. So, I guess the gnome-disk-utility should do this job (or the service which is managing the fstab). Does It work different on fedora? Should I create the mount points on my own?

thanos gravatar imagethanos ( 2016-11-24 03:13:44 -0500 )edit

If the partitions are listed in /etc/fstab, they need to exist. I don't use Gnome, so I'm not familiar with how its disk utility works. Are the partitions mentioned if fstab? If not, it may be better to do so if you're expecting them to be mounted at all times.

sideburns gravatar imagesideburns ( 2016-11-24 03:28:33 -0500 )edit

@sideburns I changed the mount location to /mnt/UbuntuMateHome and I manually created the folder with superuser rights in order to make it work. I still believe that this is a strange behavior and that it should be created on its own. I will take a look at udisks policy some day when I will have more time to spend. Thx for the help.

thanos gravatar imagethanos ( 2016-11-25 07:02:55 -0500 )edit

@sideburns Ok better solution I change the location to /media/UbuntuMateHome and it worked without creating any folder manually.

thanos gravatar imagethanos ( 2016-11-25 07:15:01 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-11-25 07:18:24 -0500

thanos gravatar image

The solution was to mount it under /media/UbuntuMateHome. Apparently, /media should be the location in which removable drives and partitions should be mounted and not /run/media, but for some reason when you mount it by the file manager or the gnome-disk-utility then it is mounted under /run/media. If you try to mount it under /run/media using fstab then it doesn't work since there is no folder media created under run yet.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-11-24 01:44:03 -0500

Seen: 270 times

Last updated: Nov 25 '16