Ask Your Question
0

How to force install with dnf?

asked 2016-11-15 16:45:16 -0500

jfha73 gravatar image

Hey guys,

I'm trying to install a few 32-bit libraries to my 64-bit system because they are needed by a 32-bit software I need to install, but when I run dnf I get this:

file /usr/share/doc/krb5-libs/README from install of krb5-libs-1.14.4-4.fc24.i686 conflicts with file from package krb5-libs-1.14.3-9.fc24.x86_64
file /usr/share/man/man5/k5identity.5.gz from install of krb5-libs-1.14.4-4.fc24.i686 conflicts with file from package krb5-libs-1.14.3-9.fc24.x86_64
file /usr/share/man/man5/k5login.5.gz from install of krb5-libs-1.14.4-4.fc24.i686 conflicts with file from package krb5-libs-1.14.3-9.fc24.x86_64
file /usr/share/man/man5/krb5.conf.5.gz from install of krb5-libs-1.14.4-4.fc24.i686 conflicts with file from package krb5-libs-1.14.3-9.fc24.x86_64

As you can see these files are just man texts and a README file of a library I cannot uninstall because it's needed by dnf and systemd.

Any ideas how can I accomplish this?

Thanks.

edit retag flag offensive close merge delete

Comments

First of all you should report this as a bug. In the meantime you can download the rpm with dnf download <packagename> and force rpm to install it: rpm -ihv --force <packagename>

fcomida gravatar imagefcomida ( 2016-11-15 17:16:22 -0500 )edit

The issue there is that the two packages are different version my suggestion will be to update those package to the current version then it will install the i686.

aeperezt gravatar imageaeperezt ( 2016-11-15 20:16:53 -0500 )edit

Oh yes their version is different, probably a problem with repo mirrors synchronization. You can try --allowerasing or wait for a while and try again.

fcomida gravatar imagefcomida ( 2016-11-16 07:15:36 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2016-11-16 18:46:16 -0500

jfha73 gravatar image

This one did it:

First of all you should report this as a bug. In the meantime you can download the rpm with dnf download <packagename> and force rpm to install it: rpm -ihv --force <packagename>
fcomida

Thanks fcomida

edit flag offensive delete link more

Comments

It's not a bug. And forcing it like that is likely to cause you problems later on.

ssieb gravatar imagessieb ( 2016-11-17 13:20:14 -0500 )edit
0

answered 2016-11-16 01:27:55 -0500

sergiomb gravatar image

updated 2016-11-16 01:28:40 -0500

krb5-libs-1.14.4-4.fc24.i686 conflicts with file from package krb5-libs-1.14.3-9.fc24.x86_64

you need have the same version , also may mean that something is need krb5-libs-1.14.3-9 , you may try use:

dnf install --allowerasing -b krb5-libs-1.14.4-4.fc24.i686  krb5-libs-1.14.4-4.fc24.x86_64

I'm not replying directly to your question because , I think want another thing than force dnf , anyway can't force dnf to ignore deps etc.

edit flag offensive delete link more
0

answered 2016-11-16 13:06:06 -0500

ssieb gravatar image

You need to do dnf update first to make sure the 64-bit libraries that are already installed are up to date. Then you will be able to install the 32-bit libraries.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-11-15 16:45:16 -0500

Seen: 22,003 times

Last updated: Nov 16 '16