Ask Your Question
0

Realtek 8192cu Fedora 18

asked 2013-02-14 19:34:05 -0500

atj gravatar image

updated 2013-02-15 05:35:03 -0500

hhlp gravatar image

I recently upgraded my laptop to Fedora 18. The drivers included for my card did not work. The connection light stayed on. After entering a password, it idles and then asks again. I downloaded the latest drivers from realtek and blacklisted the modules included (rtl8192cu)

However, I'm getting an error attempting to modprobe the new driver (modprobe 8192cu).

Here's the end of the script.

Compile make driver ok!!

Authentication requested [root] for remove driver:
rmmod: ERROR: Module 8192cu is not currently loaded
Authentication requested [root] for insert driver:
insmod: ERROR: could not insert module 8192cu.ko: Unknown symbol in module
Authentication requested [root] for install driver:
install -p -m 644 8192cu.ko  /lib/modules/3.7.6-201.fc18.x86_64/kernel/drivers/net/wireless/
/sbin/depmod -a 3.7.6-201.fc18.x86_64

The Setup Script is completed !

modprobe: ERROR: could not insert '8192cu': Unknown symbol in module, or unknown parameter (see dmesg)

Dmesg resuls in

[ 5598.806849] 8192cu: Unknown symbol kernel_thread (err 0)

Here's the lsusb

Bus 001 Device 010: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

Any ideas?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-02-15 06:56:48 -0500

It appears your kernel is newer than the one supported by the version of that driver. The driver that comes by default should work.

If you really want to use the driver you download please apply the patch found here (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1030858/comments/65) you must register to download the patch.

Altough, i suggest you remove the new driver you installed, un-blacklist the rtl8192cu, and reboot.

And then show us the problems you have. Also update to a new kernel if avaiable.

edit flag offensive delete link more

Comments

Worked great for a TL-WN821N v4 on Ubuntu 10.04 with the default kernel 3.2.0-49 (no patch needed, install.sh works) and 3.9.0-030900rc6 (needed to remove the daemonize() line and apply the patch), thanks!

eregon gravatar imageeregon ( 2013-07-24 05:22:51 -0500 )edit

Don't forget to upvote the answer if it suits you

lnxslck gravatar imagelnxslck ( 2013-07-24 17:26:41 -0500 )edit

I wish I could but with the karma system it seems I cannot.

eregon gravatar imageeregon ( 2013-07-25 03:47:52 -0500 )edit
0

answered 2014-12-26 17:21:18 -0500

q2dg gravatar image
edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-02-14 19:34:05 -0500

Seen: 8,300 times

Last updated: Dec 26 '14