Ask Your Question
1

boot error in F24: [FAILED] Failed to start Setup Virtual Console

asked 2016-10-30 15:37:53 -0500

kdg1955 gravatar image

updated 2016-10-30 15:39:28 -0500

After update to Fedora24, I have an error during startup of the service systemd-vconsole-setup. The error msg '[FAILED] Failed to start Setup Virtual Console' is shown five times in the log file '/var/log/boot.log'.

This is part of the status message after consulting with systemctl status systemd-vconsole-setup.service

Oct 30 20:46:26 xxx systemd[1]: Starting Setup Virtual Console...
Oct 30 20:46:26 xxx systemd-vconsole-setup[930]: /usr/bin/setfont failed with error code 66.
Oct 30 20:46:26 xxx systemd-vconsole-setup[930]: Cannot open font file True
Oct 30 20:46:26 xxx systemd[1]: systemd-vconsole-setup.service: Main process exited, code=exited, status=1/FAILURE

If I manually restart with systemctl start systemd-vconsole-setup.service then the service starts without error!

The seems that the order in which the services are started is erroneous. Am I right? If so, is there a tool that solved this problem? Or do I have to find out myself which is the order of the services?

If the boot sequence of the services is not the problem, then what's wrong? And why it starts manually without problems?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-10-31 06:36:52 -0500

kdg1955 gravatar image

updated 2016-10-31 06:42:48 -0500

Solution found with the help of @fcomida.

Add parameter vconsole.font=latarcyrheb-sun16 to grub with this command as root:

grubby --args=vconsole.font=latarcyrheb-sun16 --update-kernel /boot/vmlinuz-<version_nbr>.fc24.x86_64

The correct correct vmlinuz version can be found with command grubby --default-kernel.

See also Configuring GRUB 2 Using the grubby Tool

edit flag offensive delete link more
1

answered 2016-10-31 03:53:01 -0500

fcomida gravatar image

Do you have SYSFONT=True in /etc/default/grub? If so change it to SYSFONT=latarcyrheb-sun16 and rebuild grub2 with grub2-mkconfig -o /boot/grub2/grub.cfg

edit flag offensive delete link more

Comments

Thanks @fcomida. I never thought to GRUB and your suggestion was almost spot on, because change of SYSFONT made no difference. But after some googling, I added the parameter vconsole.font=latarcyrheb-sun16 to grub. Now the service start seamlessly at boot start.
See also Configuring GRUB 2 Using the grubby Tool
Question: Do I have to reset SYSFONT to True?

kdg1955 gravatar imagekdg1955 ( 2016-10-31 06:26:25 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-10-30 15:37:53 -0500

Seen: 2,165 times

Last updated: Oct 31 '16