pip3.5 installation error

asked 2016-10-22 22:54:05 -0500

andrewddo gravatar image

Hi, I need python 3.5 and pip3.5 and tried installing from this guide https://synfo.github.io/2015/11/13/Py... but I got an error trying to install pip3.5.

Any help appreciated, thanks.

sudo dnf install python35-python3-pip Last metadata expiration check: 0:00:26 ago on Sat Oct 22 20:48:12 2016.

Dependencies resolved.

Package Arch Version Repository Size

Installing: python35 x86_64 3.5.2-2.fc23 updates 17 M python35-python3 x86_64 3.5.1-1.fc23 mstuchli-Python3.5 54 k python35-python3-libs x86_64 3.5.1-1.fc23 mstuchli-Python3.5 6.5 M python35-python3-pip noarch 7.1.0-4.fc23 mstuchli-Python3.5 1.5 M python35-python3-setuptools noarch 18.3.2-4.fc23 mstuchli-Python3.5 403 k tk x86_64 1:8.6.4-2.fc23 fedora 1.6 M

Transaction Summary

Install 6 Packages

Total download size: 27 M Installed size: 146 M Is this ok [y/N]: y Downloading Packages: (1/6): python35-python3-3.5.1-1.fc23.x86_64.rpm 212 kB/s | 54 kB 00:00
(2/6): python35-python3-setuptools-18.3.2-4.fc23.noarch.rpm 677 kB/s | 403 kB 00:00
(3/6): python35-python3-pip-7.1.0-4.fc23.noarch.rpm 1.0 MB/s | 1.5 MB 00:01
(4/6): python35-python3-libs-3.5.1-1.fc23.x86_64.rpm 2.6 MB/s | 6.5 MB 00:02
(5/6): tk-8.6.4-2.fc23.x86_64.rpm 1.0 MB/s | 1.6 MB 00:01

(6/6): python35-3.5.2-2.fc23.x86_64.rpm 1.4 MB/s | 17 MB 00:11

Total 1.9 MB/s | 27 MB 00:14
Running transaction check Transaction check succeeded. Running transaction test The downloaded packages were saved in cache until the next successful transaction. You can remove cached packages by executing 'dnf clean packages'. Error: Transaction check error: file /usr/include/python3.5m/pyconfig-64.h conflicts between attempted installs of python35-python3-libs-3.5.1-1.fc23.x86_64 and python35-3.5.2-2.fc23.x86_64 file /usr/lib64/python3.5/__pycache__/__future__.cpython-35.opt-1.pyc conflicts between attempted installs of python35-python3-libs-3.5.1-1.fc23.x86_64 and python35-3.5.2-2.fc23.x86_64 file /usr/lib64/python3.5/__pycache__/__future__.cpython-35.opt-2.pyc conflicts between attempted installs of python35-python3-libs-3.5.1-1.fc23.x86_64 and python35-3.5.2-2.fc23.x86_64 file /usr/lib64/python3.5/__pycache__/__future__.cpython-35.pyc conflicts between attempted installs of python35-python3-libs-3.5.1-1.fc23.x86_64 and python35-3.5.2-2.fc23.x86_64 file /usr/lib64/python3.5/__pycache__/__phello__.foo.cpython-35.opt-1.pyc conflicts between attempted installs of python35-python3-libs-3.5.1-1.fc23.x86_64 and python35-3.5.2-2.fc23.x86_64 file /usr/lib64/python3.5/__pycache__/__phello__.foo.cpython-35.opt-2.pyc conflicts between attempted installs of python35-python3-libs-3.5.1-1.fc23.x86_64 and python35-3.5.2-2.fc23.x86_64 file /usr/lib64/python3.5/__pycache__/__phello__.foo.cpython-35.pyc conflicts between attempted installs of python35-python3-libs-3.5.1-1.fc23.x86_64 and python35-3.5.2-2.fc23.x86_64 file /usr/lib64/python3.5/__pycache__/_bootlocale.cpython-35.opt-1.pyc conflicts between attempted installs of python35-python3-libs-3.5.1-1.fc23.x86_64 and python35-3.5.2-2.fc23.x86_64 file /usr/lib64/python3 ...
(more)

edit retag flag offensive close merge delete