Ask Your Question
0

Why does plymouth-quit-wait.service takes 1 minute during boot in F25?

asked 2016-10-22 10:46:09 -0600

HoboPrimate gravatar image

I installed F25 beta fresh when it came out, and the boot time is noticeably slower than F24. Using systemd-analyse blame shows that the culprit is plymouth-quit-wait.service which takes 1min 1.981s during boot. Is this normal? Can anything be done about it?

P.S.- I have a intel+nvidia laptop, but use the default nouveau driver.

Thanks!

edit retag flag offensive close merge delete

Comments

2

@HoboPrimate first welcome to ASKFEDORA, fedora 25 is under development if you find any bug's please open a ticket in bugzilla.redhat

hhlp gravatar imagehhlp ( 2016-10-22 11:51:35 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-10-22 17:09:27 -0600

Mr. G gravatar image

If you do systemd-analyze plot > output.svg you can see that services run in parallel and plymouth-quit-wait is just there waiting for other services and Plymouth boot splash screen to finish and notify any listeners depending on that event. In fact if you do systemctl status plymouth-quit-wait.service you can read the description:

plymouth-quit-wait.service - Wait for Plymouth Boot Screen to Quit

TLDR: it's not slowing down your system.

edit flag offensive delete link more

Comments

Thanks for the info! I will give a good look at the output.svg I created and see if I can find the culprit (if any) of what I perceive as making boot slower than in F24.

HoboPrimate gravatar imageHoboPrimate ( 2016-10-29 09:00:27 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-10-22 10:46:09 -0600

Seen: 15,763 times

Last updated: Oct 22 '16