Ask Your Question

h.264 Videos not working in Firefox [closed]

asked 2016-10-19 11:42:02 -0500

elvisn gravatar image

Hi, I followed the instructions here to try to get everything working. I enabled the repo, installed the packages, enabled the plugin in Firefox's Add-ons>>Plugins, then restarted Firefox. I still get no videos on certain sites (one of the sites I use for school requires a video and needs this codec). I double-checked at , and it says that I don't have the codec installed.

I'm asking here on the Fedora forums, since videos play properly in Arch Linux (considering they just release everything as-is, and don't worry about copyright/patents in their repos).

Does anyone know why it's not working? I tried restarting my computer also, but nothing changed. If anyone could help me, that would be great!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by davidva
close date 2018-03-26 02:06:05.038477

1 Answer

Sort by ยป oldest newest most voted

answered 2016-10-19 17:17:56 -0500

David-LDA gravatar image

updated 2016-10-19 17:23:24 -0500

The OpenH264 does not play the videos you want to play in Firefox. The article you linked states:

...It does not enable generic H.264 playback, only WebRTC

Recently Firefox changed the way it uses external decoders, so there is loads of out of date info on the web. It doesn't use gstreamer any more. You need to:

  1. Enable the RPM Fusion repo by going to the terminal and entering:
su -c 'dnf install$(rpm -E %fedora).noarch.rpm$(rpm -E %fedora).noarch.rpm'

Then install the correct codecs:

sudo dnf install ffmpeg-libs

Now when you go to it should report all is well :)

On my machine I am finding some full screen videos on Youtube freeze, but it's probably a driver issue.

edit flag offensive delete link more


Wow, thanks for clear instructions! And for some extra knowledge regarding firefox...

elvisn gravatar imageelvisn ( 2016-10-20 15:30:58 -0500 )edit

Thanks for this answer! One possible tweak to it: ffmpeg-libs and its dependencies are all in the RPMFusion "free" repo, so its possible to skip enabling the "nonfree" repo while still getting working H264 video playback.

ncoghlan gravatar imagencoghlan ( 2018-01-10 01:56:49 -0500 )edit

Thanks, this is exactly the info I needed!

Charles R. gravatar imageCharles R. ( 2018-03-25 20:32:57 -0500 )edit

The instructions worked very well on Fedora 28. Video streaming worked nice. Just remember to close & reopen Firefox after installing the ffmpeg-libs.

wolfv gravatar imagewolfv ( 2018-06-26 06:10:58 -0500 )edit

It is perhaps possible that dnf install automatically upgrades http to https, but why take the risk? Also the sudo works, no need for su -c '...'. (the rpm -E gives the same results whether executed by the user or by root)

sudo dnf install$(rpm -E %fedora).noarch.rpm$(rpm -E %fedora).noarch.rpm
ejhuff827 gravatar imageejhuff827 ( 2018-07-27 08:46:53 -0500 )edit

Question Tools

1 follower


Asked: 2016-10-19 11:42:02 -0500

Seen: 33,609 times

Last updated: Mar 25 '18