Ask Your Question

Macbook Pro dual booted heating&firewall issues

asked 2016-10-18 03:16:03 -0500

Ottomanslap gravatar image

I successfully dual booted fedora with "Fedora-Workstation-Live-x86_64-24-1.2.iso" (Fedora 24). However I have a couple issues: when using fedora on my machine, the machine gets really hot even though I only use firefox and similar programs.

Another issue I have is that when trying to shut down fedora, I always have to force shut down due to the firewall not shutting down.

Thanks for any help in advance, this is my first time using any kind of linux, so I might be missing something very obvious.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-10-20 17:42:53 -0500

cmurf gravatar image

You may want to install powertop and thermald. I would install thermald first, you can find it in copr.

On the right hand side, see quick enable for the command to use to enable the copr repo, and then after that you also need to do 'dnf install thermald' to install it. There should then be a thermald.service running which you can check with 'systemctl status thermald'. This will tone down the heating quite a bit.

The other problem likely going on is Apple's firmware enables the discrete GPU by default, and depending on that GPU it may not be in a power saving mode by default. You'll get less heat and better battery life if you can figure out how to disable the discrete GPU and use the integrated GPU (i915). By figure out, I mean do some searches for your model like 'macbook <model> disable discrete gpu' or some variation of that and then do a lot of reading. In Fedora 25, there's a new feature for better GPU switching to make this more automatic, hopefully.

edit flag offensive delete link more


Thanks a lot for your help, I'll try and report my conclusions soon.

Ottomanslap gravatar imageOttomanslap ( 2016-10-21 14:49:16 -0500 )edit

Question Tools

1 follower


Asked: 2016-10-18 03:16:03 -0500

Seen: 197 times

Last updated: Oct 20 '16