Ask Your Question
1

hibernate not working fedora 24

asked 2016-10-17 01:20:12 -0500

LAYAN gravatar image
[layan@fedora ~]$ systemctl hibernate 
Failed to hibernate system via logind: Sleep verb not supported
edit retag flag offensive close merge delete

Comments

See also this question: How to enable hibernate

basic6 gravatar imagebasic6 ( 2017-01-02 02:54:22 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2016-10-17 03:09:07 -0500

TWTOoth gravatar image

try the command

$ systemctl suspend

it should work just fine

edit flag offensive delete link more

Comments

yes its working, but hibernate ?

LAYAN gravatar imageLAYAN ( 2016-10-17 05:54:10 -0500 )edit
1

answered 2016-10-17 08:33:35 -0500

jake gravatar image

Hibernation doesn't work from a standard install, this is a common Fedora 24 Bug. Click the provided link for a workaround.

edit flag offensive delete link more

Comments

Also ensure your swap space is as large as the amount of RAM you have, preferably more.

Personally, I don't see the value in Hibernate these days, as the time it takes to offload RAM and re-read it again upon wake-up is often slower than either powering off/on or using Suspend (which is almost instantaneous). Suspend does require power be continuously available during sleep, so either a laptop with good battery or permanently powered desktop.

snowolfe gravatar imagesnowolfe ( 2016-10-20 21:33:13 -0500 )edit
0

answered 2016-11-04 11:02:41 -0500

mikmik gravatar image

In Fedora 24 (and I believe it is from Fedora 22 up) the hibernate or hybrid sleep is not enabled by default. To enable it run this code as root:

#!/bin/bash
# Enable hibernation
# Using info from:
# https://psohny.wordpress.com/2015/08/13/fedora_hiber/

# Enable recovery in the /etc/default/grub
sed -i -e 's|^\(GRUB_DISABLE_RECOVERY="\)true"|\1false"|' /etc/default/grub

#Find the swapdevice
SWAPDEVICE=`grep -e '^[^#].*swap' /etc/fstab | head -n 1 | cut -d ' ' -f 1`
echo "Using SWAPDEVICE=${SWAPDEVICE} for hibernation"

#add "resume=swapdevice" to the GRUB_CMDLINE_LINUX=
sed -i -e "s|^\(GRUB_CMDLINE_LINUX=\".*\)\"|\1 resume=${SWAPDEVICE}\"|" /etc/default/grub

#Regenerate the grub config
/sbin/grub2-mkconfig -o /boot/grub2/grub.cfg

After regenerating the grub configuration, now you need to reboot your machine

reboot

Now after reboot it will be possible to hibernate or even hybrid-sleep

systemctl hibernate -i
systemctl hybrid-sleep -i
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-10-17 01:20:12 -0500

Seen: 1,651 times

Last updated: Oct 17 '16