Unable to install PostGIS on Cent OS 7 [closed]

asked 2016-10-13 11:47:55 -0500

jkatlinux gravatar image

I have been using Windows since quite long and I have recently started using Cent OS 7 Linux based system. I was interested to install PostgreSQL 9.5 and PostGIS 2.2 on my new Cent OS 7 (x64) machine. I used this YouTube tutorial to install PostgreSQL 9.5 and it works well. Secondly, I used this link to install PostGIS2.2 (spatial extender of postgresql). I skipped the first part of tutorial and ran this command:

#yum install postgis2_95 postgis2_95-client

and I am getting following error:

Error: Package: grass-libs-6.4.4-7.el7.x86_64 (@epel)
       Requires: libgeos-3.4.2.so()(64bit)
       Removing: geos-3.4.2-1.rhel7.x86_64 (@pgdg94)
           libgeos-3.4.2.so()(64bit)
       Updated By: geos-3.5.0-1.rhel7.x86_64 (pgdg95)
          ~libgeos-3.5.0.so()(64bit)
       Available: geos-3.4.2-2.el7.x86_64 (epel)
           libgeos-3.4.2.so()(64bit)
       Available: geos-3.2.2-2.el6.x86_64 (elgis)
          ~libgeos-3.2.2.so()(64bit)
       Available: geos-3.3.0-1.el6.x86_64 (elgis)
          ~libgeos-3.3.0.so()(64bit)
       Available: geos-3.3.1-2.el6.x86_64 (elgis)
          ~libgeos-3.3.1.so()(64bit)
       Available: geos-3.3.6-1_0.el6.x86_64 (elgis)
          ~libgeos-3.3.6.so()(64bit)
       Available: geos-3.3.8-2.el6.x86_64 (elgis)
          ~libgeos-3.3.8.so()(64bit)

 Error: Package: grass-6.4.4-7.el7.x86_64 (@epel)
       Requires: libgeos-3.4.2.so()(64bit)
       Removing: geos-3.4.2-1.rhel7.x86_64 (@pgdg94)
           libgeos-3.4.2.so()(64bit)
       Updated By: geos-3.5.0-1.rhel7.x86_64 (pgdg95)
          ~libgeos-3.5.0.so()(64bit)
       Available: geos-3.4.2-2.el7.x86_64 (epel)
           libgeos-3.4.2.so()(64bit)
       Available: geos-3.2.2-2.el6.x86_64 (elgis)
          ~libgeos-3.2.2.so()(64bit)
       Available: geos-3.3.0-1.el6.x86_64 (elgis)
          ~libgeos-3.3.0.so()(64bit)
       Available: geos-3.3.1-2.el6.x86_64 (elgis)
          ~libgeos-3.3.1.so()(64bit)
       Available: geos-3.3.6-1_0.el6.x86_64 (elgis)
          ~libgeos-3.3.6.so()(64bit)
       Available: geos-3.3.8-2.el6.x86_64 (elgis)
          ~libgeos-3.3.8.so()(64bit)
 You could try using --skip-broken to work around the problem

The error seems to be related to too many repositories. I have already tried to disable elgis and pgdg94 repositories. But the error seems to be persistent and I am unable to install PostGIS on Cent OS 7. Being a newbie to linux based environment, can anyone help me to resolve this error or dependencies issues?

edit retag flag offensive reopen merge delete

Closed for the following reason question is off-topic or not relevant by hhlp
close date 2016-10-13 12:12:04.681370

Comments

@jkatlinux, Welcome to ASK Fedora but this site is about fedora althought Centos is a REDHAT derivate like Fedora does but try this for a better solution -> www.centos.org/forums/

hhlp gravatar imagehhlp ( 2016-10-13 12:13:53 -0500 )edit