Ask Your Question
0

Downgrade PHP 7.X to 5.X

asked 2016-10-06 09:23:06 -0600

fullcowl gravatar image

updated 2016-10-06 09:26:03 -0600

Hey guys, i wanted to use DVWA (Damn Vulnerable Web Application) to try and test SQL-Injections on my own "server", but after following several tutorials i am stuck at some point.

I managed to open the http://localhost/ website and i am able to select the DVWA Folder, but when i click on it, it says: The Connection was reset!

Up to this point I installled apache2, mysql-server, mysql-client, php5 php5-mysql php-pear, php5-gd like it is said in the README of DVWA and then started mysql, set up a password and configured the config file of DVWA to that password. I also restarted mysql and apache2.

But in the README it says, that PHP v7.0 or later are not supported. So i used php -v to check, and it says that i have PHP v7.0.11-1!

So how do i downgrade PHP from v7.0.11-1 to a version, which compatible with DVWA?

Thanks in Advance! (Im asking this for Kali and/or Fedora..)

edit retag flag offensive close merge delete

Comments

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-10-06 23:30:59 -0600

remi gravatar image

Fedora 25 will be the first version to offer PHP 7.0 by default, and is not yet released.

Better way is to keep using Fedora 24 until your application is compatible.

Alternative solution is to use remi repository which offers Software Collections of various versions of PHP (from 5.4 to 7.1). For exemple, you can read the description of my PHP Workstation.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-10-06 09:23:06 -0600

Seen: 2,191 times

Last updated: Oct 06 '16