Ask Your Question

TTY screens in Fedora 16

asked 2011-12-03 12:09:27 -0500

Kohlrak gravatar image

updated 2014-10-01 01:11:04 -0500

mether gravatar image

For the longest time I've used the alt+f# keys to take over when a program starts eating up the I/O bandwidth (such as using the hard drive like crazy or something), since the terminals respond much, much better in those situations. However, ever since I upgraded to fedora 16 from 15, when i start x the TTYs all sort of disappear (when i use alt+f#). I get garbage characters on all of them and they don't seem to have a login method anymore. What can i do about it? I've tried searching, but i have no idea what to look for, because all my search results are coming up unrelated.

EDIT: Yeah, i mean the ctrl+alt+f1...f8 keys.

Also, i used the preupgrade method, so I don't have any idea what all of that it did and didn't do. But anyway, i'm using an ATI card. I have a feeling that this is a problem with some tty config out there, but i have no idea what it would be. As for garbage, i mean random letters then a debug message talking about it complaining that my bios is broken. I noticed i can still see parts of the original terminal (it's like it's trying to come out), but it's kinda faded and blurry (it's like it's trying to be in 2 modes at once).

edit retag flag offensive close merge delete


@ariel yes, I suppose that is the definition of x freezing. See , the problem can be quite variable. When the session is frozen, ssh in and pull / check the logs.

bodhi.zazen gravatar imagebodhi.zazen ( 2011-12-18 11:54:31 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2011-12-03 14:44:06 -0500

TTY (consoles) are working fine here with a fresh Fedora 16 installation.

I suggest you work through this link as a first step

From there, what video card do you have and can you be more specific on the "I get garbage characters" part ? I can not tell from your post if it a video card problem or a font problem or a configuration problem.

fonts are set in /etc/sysconfig/i18n or with the command setfont

setfont -v /lib/kbd/consolefonts/latarcyrheb-sun16.psfu.gz

You may specify and font you wish in /lib/kbd/consolefonts/

Font provided in kbd-misc

edit flag offensive delete link more

answered 2011-12-20 17:47:43 -0500

louisvd gravatar image

There were a few issues in the Common Bugs.

One was with the bash shell being broken. A long shot I know, but you may want to to check it.

Also when I use the TTY screens, they seem to be some kind of GUI displaying text, because it's not a normal 80x25 character screen. So are you sure your graphics driver is 100%?

Good luck.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2011-12-03 12:09:27 -0500

Seen: 5,888 times

Last updated: Dec 20 '11