Ask Your Question
1

fedora 16 text installation

asked 2012-04-11 10:21:10 -0500

ss4sgoku gravatar image

updated 2012-04-12 11:10:41 -0500

hi im noob and im trying to install fedora 16 in text mode in the installation menu i press tab and if i type linux text didnt start the text mode it start only the graphic mode my pc its a celeron 2.8 (socket 478 p4 type)and have 1g of ram im using the lxde and the xfce disk if i try the same command in the full dvd version it showme error what are the commands or the right steps to make the installation in text mode?? please help

edit: im trying to use the text mode because in the live graphic mode it became really a pain it takes almost 20 min. to showme the graphical enviroment. its really slowwwww i think its because its in live cd mode... thats why i need to start it in text mode from the begining and dont access first to the graphical desktop. please help

edit2: thanks for the answer but it doesnt work because to use it i need to start first the beauty graphical mode and after that open a terminal and type su and type anaconda --text the problem its that to do that i need to wait 20 min to start that thing... and after this 10 min to open a terminal and type that...

edit3 i have the dvd too and try the text parameter

when the dvd boot it showme 2 options 1.install or upgrade fedora 2. trobleshooting if i press tab in the first options it showme the commands that it have vmlinuz initrd=initrd.img quiet if i add the text option at the end of the sentence or edit a part or the sentence vmlinuz initrd=initrd.img quiet text vmlinuz text quiet text i also try anaconda --text initrd=initrd0.img root=live:CDLABEL=TestISO rootfstype=auto ro liveimg textinst noswap textinst rdNOLUKS rdNOMD rdNODM initrd=initrd0.img root=live:CDLABEL=Fedora-16-i386-DVD rootfstype=auto ro liveimg textinst noswap textinst rdNOLUKS rdNOMD rdNODM and didnt work after some seconds it showme an error and the pc freeze and leds of my keyboard blink this is the messages that showme initrd too large to handle, disabling initrd kernel panic - not syncing: vfs: unable to mount root fs on unkon-block(2,0) pid: 1, comm: swapper Not tainted 3.1.0-7.fc16.i686 #1 and in the dvd version if i leave it start the graphic mode it never start and showme that messange too but with more information

what can i do? what its the correct sentence to execute at first boot of dvd the text installer or fedora erease that kind of option?

edit4 i try the install in basic graphics mode it showme this sentence vmlinuz initrd=initrd.img xdriver=vesa nomodoset quiet if i add the text at the final vmlinuz initrd=initrd.img xdriver=vesa nomodoset quiet text i take this message and the ... (more)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-04-11 15:49:42 -0500

ztank1013 gravatar image

This is just a workaround but maybe you can give it a try.

After the live distro (f16) is running you may open a terminal as root run the following commands:

To become root:

su -

to start installation process in text mode:

anaconda --text
edit flag offensive delete link more
0

answered 2012-04-12 01:30:28 -0500

ztank1013 gravatar image

updated 2012-04-12 17:37:37 -0500

You are you using Fedora-16-i686-Live-Desktop.iso live CD, aren't you?

This is going to be a 2 steps process, first of all to make the text installation option available you will need to download (http://fedoraproject.org/en/get-fedora-all) the Install Media and not the Fedora Desktop Live Media.

It is a DVD and will give you the chance to drop the graphical mode passing text boot option.

Note: I did not check what exactly is the string to pass to the boot command line but accordingly to the documentation the parameter to pass is text.

Second you will have to install a fedora 16 standard. During the installation process you may try to select the LXDE package (if available).

Or after the machine comes up you may use yum to groupinstall the LXDE desktop environment and select it as your default before logging in.

sudo yum groupinstall LXDE -y

Edit:
At DVD boot select the Troubleshooting option, then tab on Install Fedora in basic graphics mode, finally add the text keyword to the proposed line and hit Enter.

Edit2:
Please take a look at this troubleshooting chapter if you still are unable to boot i text mode http://docs.fedoraproject.org/en-US/Fedora/16/html-single/Installation_Guide/index.html#ch-trouble-x86.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-04-11 10:21:10 -0500

Seen: 6,427 times

Last updated: Apr 12 '12