Ask Your Question
0

Fedora 24 messed fonts and without Antialias?

asked 2016-10-01 16:53:51 -0500

ptselios gravatar image

updated 2016-10-01 17:31:06 -0500

Hello, I just upgraded my Fedora 22 to F23 and then Fedora 24. I have some problems with the fonts. I use KDE as my DE and I don't have gnome settings installed. Fonts in KDE apps are almost fine, as it was before the upgrade. The issue with the fonts in KDE apps seems to be isolated to monospace fonts. The capital letters seems to be in bold! See the image.

image description

But Firefox/Virtual machine manager etc seems to ignore antialias settings. The strange thing is that Skype has excellent fonts! Check the image. https://ibin.co/2x19BQ61GuVy.png

My ~/.config/fontconfig/fonts.conf file is not modified from F22, and it's the following:

 <?xml version='1.0'?>
 <!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
 <fontconfig>
 <match target="font">
    <edit name="rgba" mode="assign">
        <const>rgb</const>
    </edit>
    <edit name="autohint" mode="assign">
        <bool>false</bool>
    </edit>
    <edit name="hinting" mode="assign">
        <bool>true</bool>
    </edit>
    <edit name="antialias" mode="assign">
        <bool>true</bool>
    </edit>
    <edit name="hintstyle" mode="assign">
        <const>hintslight</const>
    </edit>
    <edit name="embeddedbitmap" mode="assign">
        <bool>false</bool>
    </edit>
 </match>
 <dir>~/.fonts</dir>
 </fontconfig>

Of course, I have installed the freetype-freeworld. The ~/.Xresources contains:

Xft.lcdfilter: lcddefault

xrdb reports the correct settings:

xrdb -query
xrdb -query | grep -i xft
Xft.antialias:  1
Xft.dpi:        96
Xft.hinting:    1
Xft.hintstyle:  hintslight 
Xft.lcdfilter:  lcddefault
Xft.rgba:       rgb

The KDE settings are correct, the KDE-GTK binding (probably) works. But the fonts are really ugly. I don't know if it helps, but the problem is more visible in lower font sizes (like < 8 probably). Of course I have disabled that on KDE, but I noticed that there are some hints in /etc/fonts/conf.d

20-unhint-small-dejavu-sans.conf
20-unhint-small-dejavu-sans-mono.conf
20-unhint-small-dejavu-serif.conf
20-unhint-small-vera.conf

Any ideas?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-10-02 05:51:52 -0500

fcomida gravatar image

I have freetype-freeworld, no ~/.Xresources. My ~/.config/fontconfig/fonts.conf

<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<!-- created by lxqt-config-appearance (DO NOT EDIT!) -->
<fontconfig>
 <match target="font">
  <edit name="lcdfilter" mode="assign">
   <const>lcddefault</const>
  </edit>
 </match>
 <match target="font">
  <edit name="autohint" mode="assign">
   <bool>false</bool>
  </edit>
 </match>
 <match target="pattern">
  <edit name="dpi" mode="assign">
   <double>96</double>
  </edit>
 </match>
 <dir>~/.fonts</dir>
</fontconfig>

$xrdb -query | grep -i xft

Xft.hinting: -1

I'm using inconsolata as fixed-width (mono) font

image description

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-10-01 16:53:51 -0500

Seen: 692 times

Last updated: Oct 02 '16