Ask Your Question
1

vboxdrv not loaded error in VirtualBox. My OS: Fedora 24

asked 2016-09-30 09:00:40 -0500

Dev41 gravatar image

I have searched real many websites to solve this problem but it remains unsolved at the end. Please help me out with it. It tells : The VirtualBox Linux kernel driver (vboxdrv) is probably not loaded. You may not have kernel driver installed for kernel that is running, if so you may do as root: dnf install akmod-VirtualBox kernel-devel-$(uname -r)If you installed VirtualBOx packages and don't want reboot the system, you may need load the kernel driver, doing as root: akmods;systemctl restart systemd-modules-load.service where: suplibOslnit what: 3 VERR_VM_DRIVER_NOT_INSTALLED(-1908) - The support driver is not installed. On linux, open returned ENOENT.

edit retag flag offensive close merge delete

Comments

If you installing VirtualBox on a UEFI machine you need to sign your kernel modules or disable UEFI, You should follow rpmfusion.org Virtual box kernel module installation, is is the best way to maintaint virtualBox in Fedora. Personally will recommend to use KVM with virt-manager or boxes and avoid using VirtualBox and all its issues.

aeperezt gravatar imageaeperezt ( 2016-09-30 13:52:41 -0500 )edit
1

Wrong,... You can't disable UEFI. You got UEFI or BIOS. What you can dis-/enable is Compatibility-Mode (Legacy-Mode) and a UEFI-Feature called SecureBoot. This vboxdrv-issue is about SecureBoot. Take a look at this for further information.

jake gravatar imagejake ( 2016-10-03 07:38:53 -0500 )edit

Right I mean disable secure mode on UEFI.

aeperezt gravatar imageaeperezt ( 2016-10-04 00:23:45 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2016-09-30 17:52:38 -0500

sergiomb gravatar image

as root, please do :

dnf install akmod-VirtualBox kernel-devel-$(uname -r)

Please take a look here: http://rpmfusion.org/Howto/VirtualBox and see what is your case ...

edit flag offensive delete link more
0

answered 2017-03-25 06:55:46 -0500

0novanta gravatar image

I had the exact same problem and nothing could solve it untill I found this guide. Let me know if it helps.

edit flag offensive delete link more

Comments

the guide in question doesn't use systemd-modules-load ... , systemd-modules-load could be a problem of selinux and we got other report similar here https://bugzilla.rpmfusion.org/show_b... , please follow and comment on bugzilla.

sergiomb gravatar imagesergiomb ( 2017-03-25 09:23:17 -0500 )edit
0

answered 2017-03-21 07:28:13 -0500

basic6 gravatar image

updated 2017-04-03 04:06:52 -0500

(Assuming you already have akmod-VirtualBox and kernel-devel installed.)

This is not limited to Fedora 24 and it happens a lot after kernel updates. With every newly installed kernel, the VirtualBox kernel modules need to be rebuilt. This is done by the akmods tool and for the build to succeed, the kernel headers (kernel-devel) need to be installed.

In theory, it should just work automatically. When you reboot after installing a new kernel, the system should automatically call akmods, which would then build the kernel modules for VirtualBox. Unfortunately, the reality is that it does not always work. In some rare cases, it may be that the build fails because something in the kernel has changed (example: bug 14227 version 4.3.28). In this case, you might select the previous kernel in the boot menu until an updated version of VirtualBox has been released.

However, if this error (Kernel driver not installed (rc=-1908)) is shown, it's likely that the build failed or did not run for another reason, so the first thing to try is to run the build manually and see if that works.

Open a terminal, become root and run this command to build the VirtualBox kernel modules:

# akmods --force

If should say "OK":

Checking kmods exist for 4.9.13-201.fc25.x86_64            [  OK  ]
Building and installing VirtualBox-kmod                    [  OK  ]

If it did not say "OK", you may be missing some header files (dnf install kernel-devel and reboot) or the build might indeed fail because something in the kernel has changed and VirtualBox needs to be updated accordingly.

Note that kernel-devel (without -$(uname -r)) installs the latest version from the repository, so after updating the kernel, a reboot is usually required. Also note that akmods may have to be run with the --force option as shown above, especially when running the build manually. If you forget this option, it might simply show a warning and not do anything (Bug 4485):

Ignoring VirtualBox-kmod as it failed earlier              [WARNING]

If it did say "OK", load the modules (or reboot):

# systemctl restart systemd-modules-load

If the above steps failed, check the log file (/var/cache/akmods/akmods.log), the VirtualBox version (rpm -qi VirtualBox), your Fedora release (cat /etc/fedora-release) and kernel version (uname -r). If the build fails because of an incompatibility, you might consider opening a bug report using this information.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-09-30 09:00:40 -0500

Seen: 1,786 times

Last updated: Apr 03 '17