Ask Your Question
0

Why does Ardour5 not start unless i am using root?

asked 2016-09-25 18:27:51 -0500

David-LDA gravatar image

updated 2016-10-03 19:17:33 -0500

sergiomb gravatar image

If i start Ardour5 as a normal user from the terminal or gnome, create a session in my home directory, start Jack and press OK I get:

Loading error... Could not create session in "/home/..."

If i start Ardour5 with sudo it works... the programmer of the software in his forum directs people to ask the packagers if they get errors like this, and he says NEVER run it as root.

The software does not even start properly, I assume it is fully tested being in the official repo... what can be happening?

Name       : ardour5
Arch         : x86_64 
Epoch       : 0 
Version     : 5.3.0 
Release    : 1.fc24 
Size        : 39 M 
Repo        : @System 
From repo : updates 
Summary     : Digital Audio Workstation 
URL         : http://ardour.org 
License     : GPLv3+ 
Description : Ardour is a multi-channel digital audio workstation, allowing
     users to record, edit, mix and master audio and MIDI projects. It
     is targeted at audio engineers, musicians, soundtrack editors and
     composers.
edit retag flag offensive close merge delete

Comments

Check permissions of your ardour session directory

fcomida gravatar imagefcomida ( 2016-09-26 06:52:33 -0500 )edit

When i type ls -l the folder is:

drwxrwxr-x.  2 david david 4096 Sep 26 14:38 ardour-sessions

Where i am the user david and group david. In GNOME files it adds the following information:

Security context: unconfined_u:object_r:user_home_t:s0

Is this what it should be? It looks OK to me, but I am still quite new to Linux.

David-LDA gravatar imageDavid-LDA ( 2016-09-26 08:43:00 -0500 )edit

It seems ok. If ardour cannot load a previous session it will ask to create a new one. The problem must be somewhere else.

fcomida gravatar imagefcomida ( 2016-09-26 12:58:52 -0500 )edit

maybe you should check selinux alerts?

ceres2009 gravatar imageceres2009 ( 2016-09-27 02:44:22 -0500 )edit

thanks for the input, but I used sudo setenforce 0 to put selinux into permissive (reporting only) mode and it still did not work. I am not getting any selinux alerts on the top of the screen where they usually appear anyway.

David-LDA gravatar imageDavid-LDA ( 2016-09-27 03:30:17 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-10-17 18:11:57 -0500

David-LDA gravatar image

The answer is that i needed to join the jackuser group to gain realtime permissions to get rid of the error!

usermod -a -G jackuser yourUserId

This enables the following settings:

# Default limits for users of jack-audio-connection-kit

@jackuser - rtprio 70
@jackuser - memlock 4194304

@pulse-rt - rtprio 20
@pulse-rt - nice -20

Then you need to reboot the computer for it to take effect.

There is more important Fedora related info on this thread I started here:

https://community.ardour.org/node/13997

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-09-25 18:27:51 -0500

Seen: 1,231 times

Last updated: Oct 17 '16