Ask Your Question
0

Windows 8 not booting after Fedora 24 install

asked 2016-09-23 18:27:32 -0500

dave997 gravatar image

Hi there.

I'm writing here asking a little bit of time to those of You who want to help me with a very, very strange issue..

Put simply: I installed Fedora 24 Workstation (KDE) on 2 two different UEFI, GPT windows machines (dual boot) using exactly the same procedure (which is the standard one, with manual partitioning and the UEFI partition mounted at /boot/efi. The first (windows 10) works just fine, the other (win 8) not exactly the same..

Grub correctly created an entry for Windows Boot Loader but this simply does not work. A white, still dash appears (you know, like the terminal's blinking one) and everything stops there. I firstly thought of something gone wrong with the chainloader option, but everything seems to be ok. Don't know if this could help, but I also thought of a possible hardware-initialization issue in the win8 startup as grub comes up in a top-left 640x480 px box, instead of filling the screen (maybe windows fails to initialize the GPU because of that?). This laptop does not have any HDD light, but I'm pretty sure it's being used for a while, during the "steady-dash" phase..

And here comes the best. You guess? (unlikely..) If I type exit using GRUB's prompt, a UEFI boot media selection comes out, where I can choose HDD -> then Windows Boot Loader or Fedora. If I choose Windows Boot Loader from there, everything works fine. Except for one, final mystery: it works, but not always. A casual number of attempts of this procedure will finally bring me to a reassuring windows boot logo. Before that, the PC either restarts bringing me back to GRUB or the UEFI media selector fails to start the windows boot-loader and - again - grub pops up. THIS is the thing that is driving me CRAZY: PCs don't work casually. What the hell can cause a similar issue??

I need help since this machine isn't mine, I adviced a friend of mine to install fedora because my own experience was beautiful. So help me if you can, please.

Thank You all in advance, David

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2016-09-24 13:18:57 -0500

cmurf gravatar image

I've read about this bug before but I can't remember if it was in a bug report or on a list. It might be Secure Boot related, but I can't recommend disabling Secure Boot on a Windows system. Make sure the firmware is up to date, there are piles of UEFI firmware bugs. Basically what's you're describing is some kind of failure in the sequence of firmware>shim.efi>grubx64.efi>chainloader.mod>bootmgfw.efi, whereas when you exit GRUB you're in the firmware's boot manager, and choosing Windows Boot Loader directly picks bootmgfw.efi.

https://bugzilla.redhat.com/show_bug....
https://bugzilla.redhat.com/show_bug....

edit flag offensive delete link more
0

answered 2017-02-08 12:35:55 -0500

Ank gravatar image

its working......thank you david...........

edit flag offensive delete link more
0

answered 2016-09-25 04:50:52 -0500

dave997 gravatar image

Aah, that makes sense.. I mean, that's not exactly what I wished to hear, but at least gives an explanation to all this situation. I really have to thank you for that.

I'm then gonna look for firmware updates (if any, I don't think so..) and eventually prepare my friend to the possibility of using it as it is. In the mean time, I've found that there's a quick way of accessing that UEFI media boot selection by pressing F12 at startup, I report this just in case to could be useful to others.

In the eventuality of a UEFI firmware bug, as long as you know is there any way of changing that boot sequence in order to avoid the problem? (I know, the answer is most likely to be 'no', but I've still got hope 😅). In the mean time I'm gonna check out those links you posted, analyzing this damned buggy thing in search of a solution..

David

edit flag offensive delete link more

Comments

Hi David,

Did you solve this problem? I'm not sure whether this is a firmware bug. I got exactly the same issue with you. However, previously when I was using Fedora 23, it works pretty well. The problem happened after I install Fedora 24. I don't know if there is any change in the grub and chainloader. I'll go back and check F23 with a live os.

Yisu

yisupeng gravatar imageyisupeng ( 2016-10-31 00:22:56 -0500 )edit

Yep. It's still working. So I think it should be related to the chainloader in Fedora 24. Actually what I tried is Fedora 22 live os, but I think it's equivalent. I guess if I use the grub program in F22 to replace the grub in F24, this problem will be solved. However, I don't know the influence of such a replacement. So I'll going to do more searches.

yisupeng gravatar imageyisupeng ( 2016-10-31 01:56:03 -0500 )edit

I read this bug report, https://bugzilla.redhat.com/show_bug.... According to Kamil Páral this can be solved by downgrading grub2* to grub2-2.02-0.25.fc23 (F23 version). I'm refering to this comment: https://bugzilla.redhat.com/show_bug.... Thanks.

yisupeng gravatar imageyisupeng ( 2016-10-31 02:16:41 -0500 )edit

Thank you, @yisupeng. Right now, my friend keeps using the F12 workaround when needed, to boot windows 8. So practically never, as he mainly uses Fedora now. I wish I had a test machine in order to make further investigations as you are doing, but unfortunately that is a work computer. Anyway, even after having read what reported in the link you suggested, I can't blame Fedora community's developers, since Microsoft (and its partners) have evidently done a great job in making things annoyingly more complicated than they should have been.

dave997 gravatar imagedave997 ( 2016-11-09 11:21:34 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2016-09-23 18:27:32 -0500

Seen: 423 times

Last updated: Sep 24 '16