Ask Your Question
0

libpq-fe.h missing

asked 2011-11-08 11:47:11 -0500

jimmiy4616 gravatar image

updated 2014-09-30 09:12:37 -0500

mether gravatar image

i have install all the requirements i am trying to run a program or compile it i am getting this error the configure command works fine but make is giving me error

vanita@vanita-Inspiron-N4050:~/sanghamithra-2.0$ sh ./configure checking for a BSD-compatible install... /usr/bin/install -c checking whether build environment is sane... yes checking for a thread-safe mkdir -p... /bin/mkdir -p checking for gawk... no checking for mawk... mawk checking whether make sets $(MAKE)... yes checking whether to enable maintainer-specific portions of Makefiles... no checking for style of include used by make... GNU checking for gcc... gcc checking for C compiler default output file name... a.out checking whether the C compiler works... yes checking whether we are cross compiling... no checking for suffix of executables... checking for suffix of object files... o checking whether we are using the GNU C compiler... yes checking whether gcc accepts -g... yes checking for gcc option to accept ISO C89... none needed checking dependency style of gcc... gcc3 checking for library containing strerror... none required checking for gcc... (cached) gcc checking whether we are using the GNU C compiler... (cached) yes checking whether gcc accepts -g... (cached) yes checking for gcc option to accept ISO C89... (cached) none needed checking dependency style of gcc... (cached) gcc3 checking for gcc... (cached) gcc checking whether we are using the GNU C compiler... (cached) yes checking whether gcc accepts -g... (cached) yes checking for gcc option to accept ISO C89... (cached) none needed checking dependency style of gcc... (cached) gcc3 checking how to run the C preprocessor... gcc -E checking for grep that handles long lines and -e... /bin/grep checking for egrep... /bin/grep -E checking for ANSI C header files... yes checking for pkg-config... /usr/bin/pkg-config checking pkg-config is at least version 0.9.0... yes checking for PACKAGE... yes checking for sys/types.h... yes checking for sys/stat.h... yes checking for stdlib.h... yes checking for string.h... yes checking for memory.h... yes checking for strings.h... yes checking for inttypes.h... yes checking for stdint.h... yes checking for unistd.h... yes checking locale.h usability... yes checking locale.h presence... yes checking for locale.h... yes checking for LCMESSAGES... yes checking libintl.h usability... yes checking libintl.h presence... yes checking for libintl.h... yes checking for ngettext in libc... yes checking for dgettext in libc... yes checking for bindtextdomaincodeset... yes checking for msgfmt... /usr/bin/msgfmt checking for dcgettext... yes checking if msgfmt accepts -c... yes checking for gmsgfmt... /usr/bin/msgfmt checking for xgettext... /usr/bin/xgettext checking for PQfinish in -lpq... yes checking postgres.h usability... no checking postgres.h presence... no checking for postgres.h... no checking whether to include PostgreSQL support... no configure: creating ./config.status config.status: creating Makefile config.status: creating src/Makefile config.status: creating pixmaps/Makefile config.status: creating reports/Makefile config.status: creating man/Makefile config.status: creating po/Makefile config.status ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-11-08 12:13:45 -0500

mooninite gravatar image

Yes, the header file name is not obvious as to what package it comes from. However, I know that it comes from postgresql-devel (libpq).

In the future, you can use yum to try and find a match for a missing file.

yum install /usr/include/libpq-fe.h

edit flag offensive delete link more

Question Tools

Stats

Asked: 2011-11-08 11:47:11 -0500

Seen: 12,161 times

Last updated: Nov 08 '11