Ask Your Question
0

Why is dnf not removing the older version of gmp? [closed]

asked 2016-09-16 09:38:07 -0500

Giordano gravatar image

If I perform a sudo dnf info gmp I get this:

Nome        : gmp
Arch        : x86_64
Epoca       : 1
Versione    : 6.1.0
Rilascio    : 2.fc24
Dim.        : 747 k
Repo        : @System
Dal repo    : koji-override-0
Sommario    : A GNU arbitrary precision library
URL         : http://gmplib.org/
Licenza     : LGPLv3+ or GPLv2+
Descrizione : The gmp package contains GNU MP, a library for arbitrary precision
            : arithmetic, signed integers operations, rational numbers and
            : floating point numbers. GNU MP is designed for speed, for both
            : small and very large operands. GNU MP is fast because it uses
            : fullwords as the basic arithmetic type, it uses fast algorithms,
            : it carefully optimizes assembly code for many CPUs' most common
            : inner loops, and it generally emphasizes speed over
            : simplicity/elegance in its operations.
            : 
            : Install the gmp package if you need a fast arbitrary precision
            : library.

Nome        : gmp
Arch        : x86_64
Epoca       : 1
Versione    : 6.1.1
Rilascio    : 1.fc24
Dim.        : 747 k
Repo        : @System
Sommario    : A GNU arbitrary precision library
URL         : http://gmplib.org/
Licenza     : LGPLv3+ or GPLv2+
Descrizione : The gmp package contains GNU MP, a library for arbitrary precision
            : arithmetic, signed integers operations, rational numbers and
            : floating point numbers. GNU MP is designed for speed, for both
            : small and very large operands. GNU MP is fast because it uses
            : fullwords as the basic arithmetic type, it uses fast algorithms,
            : it carefully optimizes assembly code for many CPUs' most common
            : inner loops, and it generally emphasizes speed over
            : simplicity/elegance in its operations.
            : 
            : Install the gmp package if you need a fast arbitrary precision
            : library.

Pacchetti disponibili
Nome        : gmp
Arch        : i686
Epoca       : 1
Versione    : 6.1.1
Rilascio    : 1.fc24
Dim.        : 305 k
Repo        : updates
Sommario    : A GNU arbitrary precision library
URL         : http://gmplib.org/
Licenza     : LGPLv3+ or GPLv2+
Descrizione : The gmp package contains GNU MP, a library for arbitrary precision
            : arithmetic, signed integers operations, rational numbers and
            : floating point numbers. GNU MP is designed for speed, for both
            : small and very large operands. GNU MP is fast because it uses
            : fullwords as the basic arithmetic type, it uses fast algorithms,
            : it carefully optimizes assembly code for many CPUs' most common
            : inner loops, and it generally emphasizes speed over
            : simplicity/elegance in its operations.
            : 
            : Install the gmp package if you need a fast arbitrary precision
            : library.

and if I do sudo dnf list gmp I get:

sudo dnf list gmp
Ultima verifica della scadenza dei metadati: 1:18:01 fa il Fri Sep 16 15:12:11 2016.
Pacchetti installati
gmp.x86_64                                  1:6.1.0-2.fc24                           @koji-override-0
gmp.x86_64                                  1:6.1.1-1.fc24                           @System         
Pacchetti disponibili
gmp.i686                                    1:6.1.1-1.fc24                           updates

Why are there 2 versions of gmp installed? can I delete the older one?

If I try to delete version 6.1.0-2.fc24 dnf allows me to proceed.

If I try the other version it refuses because I'd delete dnf and systemd.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by sideburns
close date 2016-09-16 12:24:47.249211

Comments

This is a duplicate of this post. Please follow the rules about duplicate posting. Closing.

sideburns gravatar imagesideburns ( 2016-09-16 12:23:21 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-09-16 10:48:27 -0500

fcomida gravatar image

I bet you downloaded 6.1.0-2 from koji for some reason and installed it locally. Remove that package and then dnf should update normally.

edit flag offensive delete link more

Comments

actually I reinstalled Fedora couple of months ago.

Anyway I deleted it and everything works as expected now

Thanks

Giordano gravatar imageGiordano ( 2016-09-17 02:18:11 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-09-16 09:38:07 -0500

Seen: 116 times

Last updated: Sep 16 '16