Ask Your Question
2

System will not boot after installing Fedora 24

asked 2016-09-06 14:56:48 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

System is an i5 desktop without UEFI boot in BIOS. Uses separate hard drives to boot from Windows 10 and Linux, Windows is on SATA 0 (Seagate 250gb) and Linux is on SATA1 (WD Blue 500gb). Windows 10 loads and runs perfectly with SATA 0 as single drive in system, or with SATA1 when it is unformatted or as a spare NTFS drive. Can run Fedora "Live DVD" and install to SATA1 without issues, installation completed successfully following "prompts" to let it use the second (SATA1) hard drive as the target. Once installed - user is told to reboot system and enjoy Fedora, but on reboot or cold start system hangs abruptly when BIOS probes hard disks. This requires hard reset to return to running state, but only gets to the hard disk probe and no further.

  1. Removing (unplugging) SATA1 from motherboard allows system to return to normal operations and discover drives, boot normally into Windows.
  2. Any SATA1 is attached with Fedora installed to it, the system refuses to boot.
  3. BIOS does not have options for "Secure Boot" or UEFI to disable or change.
  4. Drive must be wiped to raw state (unallocated) to be usable in the system.

I am at a complete loss, this appears to be only with Fedora as I have successfully used Mint and OpenSUSE without any issues.

Any thoughts?

Motherboard is Gigabyte GA-P55-USB3 R2.0, Intel i5 (1156), with 8gb memory. SATA drives are attached to Motherboard SATA slots 0 and 1 with ODD on 3, removable docks on 5 and 6 (empty at this time).

Charles.

UPDATE: Downloaded Fedora KDE spin, burned to DVD and installed onto different hard drive and is attached to SATA4 thru mobile tray... System boots normally - finds all drives but not grub boot loader. Working on that now.

Charles.

edit retag flag offensive close merge delete

Comments

Try turning off any native RAID options, like Intel's fast boot. You want to have ACHI non-raid storage mode. In the past, I have needed to zero out the beginning of drives with dd to remove incompatible firmware RAID metadata from the beginning sectors. Note that if you have an existing Windows installation on FastBoot, you might break Windows by disabling the feature.

randomuser gravatar imagerandomuser ( 2016-09-10 13:50:12 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-09-06 22:55:27 -0500

CBHedricks gravatar image

updated 2016-09-09 12:21:41 -0500

There appears to be an issue with the Workstation edition of Fedora 24 and my system bios. No matter if the HD that has Fedora WS is primary or secondary or even as stand alone it locks up the computer during the BIOS drive scan. I downloaded and installed the KDE spin and it works perfectly.

The Workstation edition HD is usable in a different AMD based system, also in an earlier Core 2 Quad system so it has to be something to do with the GA-P55USB3 bios.

Charles

UPDATE: - The issue seems to be related to Fedora Workstation (Gnome) having issues with the Intel p55 BIOS. When BIOS probes for hard drives, any drive with Workstation installed locks up the system at Drive Detection, never allows it to find the hard disks attached to the motherboard controller. As I do not have a POST code reader, I can only infer this information. I am trying to see if I can find a POST code card to use, one that will narrow down what signals are being tampered with.

CB

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-09-06 14:56:48 -0500

Seen: 718 times

Last updated: Sep 09 '16