Ask Your Question
2

Google Chrome missing after the update

asked 2016-09-01 09:35:29 -0500

masteroman gravatar image

Well, this is not exactly a question but rather story about what i experienced today. I upgraded my system and besides all Google Chrome was updated to version 53. What I have noticed immediately after the upgrade was that there was no Google Chrome icon in gnome shell anymore.

I looked into launcher and found what it was trying to run:

$ grep ^Exec /usr/share/applications/google-chrome.desktop 
Exec=/usr/bin/google-chrome-stable %U
Exec=/usr/bin/google-chrome-stable
Exec=/usr/bin/google-chrome-stable --incognito

Looking further it looks like there was no /usr/bin/google-chrome-stable symlink anymore:

$ ls -ld /usr/bin/google-chrome /usr/bin/google-chrome-stable /usr/share/applications/google-chrome.desktop
ls: cannot access '/usr/bin/google-chrome-stable': No such file or directory
lrwxrwxrwx. 1 root root   31 Sep  1 16:21 /usr/bin/google-chrome -> /etc/alternatives/google-chrome
-rw-r--r--. 1 root root 8445 Aug 31 01:50 /usr/share/applications/google-chrome.desktop

Finally I have solved it by creating an symlink for it:

$ sudo ln -s /opt/google/chrome/google-chrome /usr/bin/google-chrome-stable

I should probably report this somewhere, does anybody knows where? :-)

edit retag flag offensive close merge delete

Comments

You do not mention how you installed if you use google repos you should report a bug there.

aeperezt gravatar imageaeperezt ( 2016-09-01 09:39:08 -0500 )edit

Direct download from their site a while ago which installed also their repo. Update using their repo broke the things. Ok, I'll find the right location there and report. Thanks.

masteroman gravatar imagemasteroman ( 2016-09-01 09:48:01 -0500 )edit

I had the same problem after updating today. Thank you very much!

Tolu gravatar imageTolu ( 2016-09-01 12:11:24 -0500 )edit

I had the same problem and resolved it the same way. I also notice that, since the update, I'm disconnected from every site each time I reboot my computer. I need to login every time. Anyone has this problem ?

sebastiencs gravatar imagesebastiencs ( 2016-09-01 18:41:20 -0500 )edit

I also had the same problem after updating today. The command you posted fixed it.
Thank you.

wolfv gravatar imagewolfv ( 2016-09-02 00:11:45 -0500 )edit

6 Answers

Sort by ยป oldest newest most voted
2

answered 2016-09-02 08:52:20 -0500

cschanzle gravatar image

easier for terminal lovers:

sudo dnf -y reinstall google-chrome-stable

The suggestion to create the symlink doesn't also fix the /usr/bin/google-chrome-stable issue and perhaps other symlinks or "things" that might become significant in the future. The multi-platform rpm post scriptlets are a mess to follow - view with:

rpm -q --scripts google-chrome-stable | less
edit flag offensive delete link more

Comments

Looks like yet another update today, version 53.0.2785.92-1, which did make a bunch of edits to the scriptlets, hopefully this will resolve the issue, but I cannot verify since I reinstalled on all my systems.

cschanzle gravatar imagecschanzle ( 2016-09-02 22:15:51 -0500 )edit

Unfortunately that didn't helped with version 52. No matter how I installed it, and I tried:

  • removing chrome completely and installing it again
  • reinstalling via dnf reinstall
  • plain upgrading from 51

Result was always the same, symlink missing. Looks like they have fixed this in 53 :-)

masteroman gravatar imagemasteroman ( 2016-09-10 00:18:55 -0500 )edit
0

answered 2016-09-03 21:33:42 -0500

mjay gravatar image

updated 2016-09-05 13:07:30 -0500

Today I saw an update for Google Chrome in the software center.

I had already read this thread, and turns out there are other bugs with google chrome which are solved by updating manually.

sudo dnf update google-chrome is what I did when I saw today's update and I havent had any problems.

EDIT: Just to be clear. I did not update chrome via the software center. When I saw the update was available I used dnf and everything was fine.

edit flag offensive delete link more
0

answered 2016-09-02 05:51:17 -0500

Sorry to pile on, but I had the same issue today as well. command provided was the fix, thanks so much!

edit flag offensive delete link more
0

answered 2016-09-01 22:59:30 -0500

Same issue here, fedora 24 + Chrome missing after yesterday's update. Personnally I uninstalled Chrome through the official software manager and reinstalled downloading the package from Google. I got everything back to normal this way. Didn't even have to set everything up.

edit flag offensive delete link more
0

answered 2016-09-02 14:12:42 -0500

steeve gravatar image

Had the same problem today, used a similar solution (create symlink to /opt/google/chrome/google-chrome).

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2016-09-01 09:35:29 -0500

Seen: 1,749 times

Last updated: Sep 05 '16