Ask Your Question
1

fstab still doesnt work on f16

asked 2012-05-13 01:52:42 -0500

la7low gravatar image

Hi All, I can mount a network drive with mount without problem: mount -t cifs //192.168.1.1/share /media/NAS I can see the files afterwards. I put the following to fstab for automount: //192.168.1.1/share /media/NAS cifs defaults 0 0 but the network share is not mounted after restart.

I also modified the /etc/fstab line to: "//192.168.1.1/share /media/NAS cifs guest,_netdev 0 0" and ran "mount -av", I got the following message:

"mount.cifs kernel mount options: ip=192.168.1.1,unc=\192.168.1.1\share,guest,ver=1,user=,pass=** nothing was mounted"

It seems it can't use the "_netdev" option, doesn't it? Why? What to do? Automount still not working....Any suggestions warmly welcomed! Thx!

(I am using fedora 16 with latest updates.)

edit retag flag offensive close merge delete

Comments

Automounter running?

lzap gravatar imagelzap ( 2012-06-21 08:09:11 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-06-30 16:10:09 -0500

mavit gravatar image

You mention "automount" several times. The automounter is a daemon that mounts filesystems on demand (i.e., whenever you try to use them), and isn't controlled by /etc/fstab.

So, although this doesn't answer you question directly, you could use the automounter to mount your filesystem instead of at boot-time. You'll need to install it with yum install autofs. You can then download the auto.cifs script to have the automounter mount the CIFS filesystem for you simply by looking in /cifs/192.168.1.1:share.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-05-13 01:52:42 -0500

Seen: 711 times

Last updated: Jun 30 '12