Ask Your Question
1

Macbook Pro 5,3 installation

asked 2013-01-10 11:54:37 -0600

wutzi gravatar image

I'm trying to install fedora 18 beta on a Macbook Pro 5,3. I tried different installation media (USB, SD-Card, DVD, Fedora 17 CD...). I also installed reffit. Everything runs fine until fedora starts booting after GRUB. I get the usual verbose output of a booting kernel, but then I just see some strange graphics error (colorful lines on screen) and nothing happen even if I wait for a long time.

Some time ago I had ubuntu running on it so I know it's possible, but somehow it doesn't seem to work now. Maybe it is because of the two graphics cards?

The last message is:

fb: conflicting fb hw usage nouveaufb vs. EFI VGA - removing generic driver

edit retag flag offensive close merge delete

Comments

I have the same issue on my MacbookPro5,5 (only 1 video card though)?

dejl gravatar imagedejl ( 2013-03-27 06:55:11 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-01-09 09:14:28 -0600

PG gravatar image

updated 2014-04-03 09:16:03 -0600

I had problems installing Fedora 20 on Macbook Pro 5,5 via both VirtualBox and as dual boot on a partition. After loading the initial text prompts, the Fedora installation appeared to stop, with a blank screen. I determined the problem to be incompatible graphics.

Refind/Refit are not needed if the mac is running 10.9.

Use Disk Utility to make the size of your main/boot HDD smaller by >30MB, to have enough free space for installation, additional software and future kernel updates.

Hold left Alt/Option key during boot. Insert installation media.

When installation text prompt appears, choose Troubleshooting, then Choose basic graphics mode. You should be able to continue installation, though you will not have a wireless connection, so please connect to LAN via ethernet.

(See elsewhere for instructions to install wireless drivers for your particular wireless radio chipset.)

edit flag offensive delete link more
0

answered 2013-01-12 02:58:02 -0600

Emin Tufan gravatar image

When GRUB loading, edit Fedora entry before booting Fedora. Delete this line:

set gfxpayload=keep

And boot Fedora. If your problem solved after that, open /boot/grub2/grub.cfg file, find and delete "set gfxpayload=keep" line then save. (This operation needs root permissions)

edit flag offensive delete link more

Comments

when editing '/boot/grub2/grub.cfg' please note the comment in the top of the file:

'#

DO NOT EDIT THIS FILE

#

It is automatically generated by grub2-mkconfig using templates

from /etc/grub.d and settings from /etc/default/grub'

Jann5s gravatar imageJann5s ( 2014-04-04 03:13:55 -0600 )edit

Question Tools

Stats

Asked: 2013-01-10 11:54:37 -0600

Seen: 1,695 times

Last updated: Apr 03 '14