Ask Your Question
2

How to disable packagekit?

asked 2016-08-18 16:11:32 -0500

ceres2009 gravatar image

i tried disabling packagekitd since i only use dnf anymore - with

sudo systemctl disable packagekitd

but after reboot:

sudo service packagekit status
Redirecting to /bin/systemctl status  packagekit.service
โ— packagekit.service - PackageKit Daemon
   Loaded: loaded (/usr/lib/systemd/system/packagekit.service; static; vendor preset: disabled)
   Active: active (running)

i also tried removing, but it will remove around 40 packages (probably the ones installed w/ gnome-software)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-08-18 16:14:57 -0500

skytux gravatar image

In my case I masked the service:

$ sudo systemctl mask packagekit.service
edit flag offensive delete link more

Comments

florian gravatar imageflorian ( 2016-08-19 10:26:08 -0500 )edit

I think the thread you're referring to is here:

https://ask.fedoraproject.org/en/ques...

It suggested the following. I hope it works.

[xxxxx@xxxxx ~]$ sudo systemctl mask packagekit.service
[sudo] password for xxxxx: 
Created symlink /etc/systemd/system/packagekit.service โ†’ /dev/null.
[xxxxx@xxxxx ~]$
graceful gravatar imagegraceful ( 2017-03-29 03:58:20 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-08-18 16:11:32 -0500

Seen: 4,787 times

Last updated: Aug 18 '16